System Cleaner will not start

Downloaded System Cleaner and it worked the first day. Second day, I couldn’t start it. Mousing over the icon revealed it was all gray’d out. Uninstalled and then re-installed but it still will not start / come up. Again, mousing over the tray icon reveals a gray screen. I’m running Vista Ultimate 32 bit SP2.

Hello Malchyt;

To verify;
You have uninstalled CSC from Add/Remove OR Programs and Features and then downloaded a fresh copy from
Then once downloaded you right click > Run as Admin


Hi Jake and thank you for the info. Yes, I did all that and when I saw your post, I did it all again but I’m getting the same thing. When it’s first installed, I get the pop-up that says it’s going through various cleaning cycles, but when I try to open the Ap, it won’t open. Mousing over the icon in the tray again reveals a gray screen.


Can you post some sreenshots with your problem?

2 files are attached - both are mouse overs of icons in the tray. System Cleaner is all gray and will not start. Viable icons display the pages they’re on. There isn’t much more to it than that I’m afraid.

[attachment deleted by admin]

I am running Win7 Pro x64 in a custom machine.

Just wanted to piggy-back onto what Malchyt is experiencing.

I DLed and successfully used CSC on a few occasions. Eventually I experienced what Malchyt is experiencing: CSC launches but it then hangs in “loading” mode (which is why all of the options are grayed out); only the toolbar options (settings, about, etc.) are available.

I ran the repair option from the ComodoSC . . .exe file: did not fix; I erased (Revo) and reinstalled CSC: issue persists. I, at first disabled, then uninstalled all AV/anti-malware apps: issue still persists.

The only changes in my OS between the time I first launched CSC, when it worked normally, and now it the result of routine disk/reg clean procedures I employ prior to making routine image backups. I think that, if these procedures corrupted CSC, the reinstall would have corrected that. No fix to date.


CSC launches but it then hangs in "loading" mode (which is why all of the options are grayed out); only the toolbar options (settings, about, etc.) are available.

I have got same problem with Free CSC on my windows 7 64-bit


It seems that many people have this same problem running CSC. CSC just keeps “loading” forever and all scan options are grayed out. There seems to be no support from Comodo.

Check if local service COMODO System - Cleaner Service is running.

If not check properties of that service and change from Manual to Automatic then “Start”

Solved my “loading” problem

Good luck

i had a similar problem on windows 7 x86 but mine was just showing up with the unknown application icon but would not load. i found that if you go into the program file (which should be C:/Program Files/COMODO/COMODO System Cleaner) and go into the properties of CSC.exe check to make sure it is not set to read only. That was the problem with mine some how it became a read only file so i unchecked it and bam it worked again.

Reinstalled CSC toady and it is functioning normally. If the issue recurs I will post back.