System Cleaner has not uninstalled properly

Hi Forum
After issues with the latest update that imposed itself upon my otherwise happy existence I decided to uninstall comodo system cleaner through add/remove programs.

But there was a freeze up mid process, however the listing for the comodo system cleaner went away from the program list in add/remove programs and the start programs list.

But then cleaner_validator.exe kept popping up and also when running anti virus (not a comodo product) it exits early with a cleaner_validator.exe error message.

When I checked the system cleaner’s install folder its all still there. I tried to re-install (so I could uninstall) but the installer is of course the previous version I downloaded originally and it sees the newer version and quits.

How can I tell if anything is still installed and if its not can I just delete the folder and have done with it?



This software has more bugs than a cheap hotel. It devastated two restore points until I found free software on Watching the program being removed pointed out how complicated and involved the program is. Won’t ever touch System Cleaner again. I have had good success with their Security software.

Hi Likini
Are you saying that you have some software that has uninstalled system cleaner?

If so what is the software called,

Please provide a link to the software.



The software is called Revo uninstaller. Comes in two version: the free and the deluxe which you pay for.The free version is very good and will fill your needs. Go to where you can download the program and read what others say about it.
I know your frustration as I spent hours trying to get rid of System Cleaner and in the meanwhile screwing up my computer.

Hi Likini
Thanks but the free version of REVO just doesn’t see the comodo system cleaner as being installed, so no joy,

I tried to delete the comodo folder but cleaner.validator.exe would not delete.

I ran CSC from the install folder on the C:\ and it still works and runs so I guess it is still fully installed??

Even though the icons are gone from add/remove programs and the start programs list.

Is this uninstall problem a dirty trick that comodo plays on people?

I am not getting any help from comodo : C

You can try downloading the Cleaner from the Comodo site again. Revo picked up my partial program an uninstalled it. If you remember when you tried to use the Comodo uninstaller it ran up to certain point and a pop up message says that there is an error. When you run Revo it hits the same snag but forces it’s way through the “bug”.
When I tried to uninstall with Comodo there is a uninstall and repair link. It doesn’t really install but goes through the install mode. See if you can use this link which is: START>PROGRAMS>COMODO>UNINSTALL/REPAIR which should put a full copy on your computer so REVO can recognize it.