synTPEnh.exe -> cfp.exe locks up mouse on laptop

Set up:

  • Windows XP Professional SP3
  • Fujitsu Lifebook S6410P laptop

While using the mouse pad on the laptop I get from time to time the Comodo Firewall indicating that the application “synTPEnh.exe” to “cfp.exe” needs a decision.

With the pop up the mouse pointer locks up. I can tab in the Comodo window but cannot move the mouse to click on any of the options. Even when I choose to remember the response and choose to trust the application I tab to the OK button and press the return key. The window does not disappear and the mouse remains locked up.

It remains this way for several minutes. Eventually the window disappears and as I go to scroll on the mouse pad it locks up again.

Again I tab through and choose the options again. I have even tried to choose that it is a window application. Nope with any long term success.

Look forward to knowing what the solution is.

Does the alert say if tries to access cfp.exe in memory? Then read the following.
The program is trying to access CIS in memory which is not allowed by default. We are going to make an exception for the program so it can access CIS in memory.

Here is the drill. First go to Defense + → Advanced → Computer Security Policy.

Now look up Comodo Internet Security → select it → Edit → Protection settings → click on the Modify button behind Interprocess Memory Access.

We are going to add your program to the exceptions: Add → Browser → now browse to the file and select it → Apply → Apply → Apply.

Now start the program and see what happens.

The easiest fix is to connect an external usb mouse to your laptop. Make sure the mouse is working. Then get back on the touchpad and hit the scroll on the touchpad. The comodo warning will pop up. Use the external mouse to move the curser to allow and make sure remember my answer is checked. You wont have that problem anymore and you can disconnect the external mouse

donellb sent the following reply:

The easiest thing to do when the scroll locks up your touchpad is to connect an external usb mouse, then hit the scroll on your touchpad to make the message come up and then use the external mouse to click allow. I would have posted this on the board, but I cant figure out how to do it. I hope you get this.

Hi donellb,
Thanks for the feedback. Good to read that this issue doesn’t affect the external mouse.

The solution is fine if you have an external mouse handy. It is far better if Comodo fixes this issue for laptops.

I’ll post your comments and mine on the board.