Switching configurations

V12.2.2.7036 (Firewall only) Windows 7 Ultimate 64-bit

I do not quite get the following behavior regarding switching configurations.

Under “General Settings->Configuration” there is three default configurations plus one added by myself as follows (I number them for reference):

1 : “COMODO - Internet Security”
2 : “COMODO - Proactive Security”
3 : “COMODO - Firewall Security”
4 : “COMODO - Firewall Security -” Active

No.1 and no.2 are not in use and can be ignored.

No.4 is an exported and imported version of no.3 just with a different name

No.4 is set to Active.

Now when I add a Firewall Application Rule (let’s say for ping.exe) and then switch to no.3 (so making no.3 the Active one) I get asked “Would you like to save your changes to current configuration before switching configurations?” and I then select NO and next select OK when it tells me “The configuration has been activated successfully.” and then when I switch back again to no.4 (again answering NO on save and OK on successfully) I would expect that the Firewall Application Rule for ping.exe would not exist anymore because I didn’t save any configuration while switching between no.4 and no.3 and back to no.4 again.

So question is why does an added Firewall Application Rule still exist while switching configurations and back again while not saving anything?

Is anybody trying to reproduce this?

If click in no setting clean (other name);
If click in yes setting save in default (comodo internet security - comodo proactive security - firewall security);
this also occurs when update version

To add to my first post:

It happens with all settings, not alone when adding or changing Firewall rules.

For simple and easy demonstration one can use “General Settings->User Interface->Show desktop widget” and toggle that option on or off while doing the same thing as written in the first post.

In general the question now is:

Why does a change in any setting still exist (and not revert) while switching configurations and back again while not saving anything?

Hi liosant,

Thank you very much for your answer.

“If click in no setting clean (other name);” → I would expect that it would work like that but unfortunately it doesn’t.

When click in no the settings do not take over the settings of the last Active configuration in which a change in setting was performed and no save was done.

See it like having a Undo function, when you make several changes in the current Active configuration and you would like to Undo those changes by making another configuration Active and then go back to the previous configuration and making that Active again then the changes are not Undone instead they are permanent (when click in no each time when changing Active configuration).

I think this “not working Undo function” as described in previous post is a bug, I’m on the verge to file a bug report.

I would like to have the opinions of other users and/or members on this forum about this.

Please let me know how you think about it.

No one cares about this problem? ???

I haven’t tried to reproduce this but by reading your first post this definitely looks like a Bug. The added rule should not exist when switching back to the config if you pressed NO when asked about saving changes to current config before switching.

I think you should try filling a Bug Report - The worst that can happen if not a Bug is that it will be either submitted as a Wish instead or moved to Rejected.

Thanks for your feedback mmalheiros.

I was already thinking that no one understood (or not willing to understand) the real problem here, I’m glad you did! :slight_smile:

The bug will be reported definitely, switching configs and selecting NO on save just doesn’t work.

Why do I always find these kind of bugs, sigh.

You doing a good job in reporting your findings, I personally don’t have time to try to discover such issues, only once I tried to report a issue in which the HIPS (with disabled Containment) was failing against Ransim Ransomware Simulator under Proactive Configuration on Win7 x64 and V12.0.0.6882 but in the end it was submitted as a Wish instead, since I had no time to uninstall V12, reinstall V10 or V11 (which achieved a perfect score back then) just to test. Containment enabled always achieved a positive score against Ransim, for which I regarded the issue as not so important and moved on.

It’s definitely a good thing if you report possible issues you find even if they turn out to not be a issue in the end.

To stay on topic, I read all your posts in this thread and I think this is definitely a Bug, probably the NO/Don’t save changes option is broken.

I tried to reproduce this behavior on Windows 10 2004 (19041.264) but it did not reproduce. This is a clean install of both Windows 10 and CIS. In CIS I use and imported modified Proactive Security Profile called My Proactive that I imported. That profile was renewed approx 1,5 months ago and I consider it to be ‘clean’.

I first tested toggling between the Proactive Security profile and My Proactive Security profile but could not reproduce. I then tested toggling between two Firewall profiles (I made a second one for the test) and again it did not reproduce. Although I changed to the Firewall profiles the AV still was active which I did not expect. In order to test without the AV I will may have to go through Program and Features and change the installation. I did not try this.

May be it is an issue with Windows 7 only? Are there Windows 7 users willing to test this?

When I tried on my Windows 7, I did not replicate the issue.

I am currently booted on Windows 10 1809 (17763.1158) but could not reproduce it here either.

Maybe I can try this but first I have to upgrade to V12.2 as I am still on

I switched CIS to Comodo Firewall and rebooted to make the changes effective. I could not reproduce the findings (Windows 10 1809).

There are three options as far as I can see:

  1. The problem only happens on Windows 7
  2. The problem could be confined to only Firewall only (futuretech, did you test on CIS of Comodo Firewall?)
  3. The installation of CISfan has gotten corrupted (are you willing to try a clean installation of the Firewall?)

can’t attach a mp4 or 7z of only 4Mb size to show the issue, oh well so be it.

I believe what you are witnessing. Your description is clear and it allows us to try to reproduce it.

We need to exclude the possiblity that your configuration/installation is corrupt. I have had it happen where I found a bug with CIS but it did no longer reproduce when I started with a clean profile. The old profile was approximately 1,5 y/o and had been used with various versions (some updates I used the program updater and some I did clean importing the old profile).

Hence my question to try a clean installation. It is the only way to know if the issue is with CIS or with profile/installation. This is a mandatory step in bug reporting.

Having tested this over the last few days, I can probably confirm what CISfan says . . .

On a Win10x64 Pro 1909 (18363.836) system which had CIS clean installed and my Proactive Config imported 3 days ago, I could replicate the point he raised, but as a last test, I scrapped the imported Config I had used over several months and rebuilt a brand new one created from the default Proactive

As he said, any FW rules created in a different Config and then not ‘Saved’ when changing Configs, remain when swapping back to check them

Having said that, it’s not something I’d ever come across as I’d always Export and then Import with a new name before altering anything - the same as editing any Document or Graphic

Whether this is considered a bug or if it should be treated as an ‘Undo Feature’ at all, is debatable and I haven’t done a clean CIS install and new Config at the same time - there is 3 days between

Hello Dharshu,

Do you have any news regarding this issue?
Ploget could reproduce the issue. Could you or you teams reproduce the issue too?
Is it already confirmed?

Thank you.

Hello CISfan,

Yes,I can able to reproduce this issue on Win 10 x64 bit and it’s reported to dev team and they are working in it.
Thank you.

Have a nice day,