Supreme Commander Forged Alliance issues (last update, feb 2009)


I’ve been forced to remove comodo cause it was no more allowing the execution of a game. The game is:

Supreme Commander - Forged Alliance

Before the update of comodo, everything was working fine. After the update, the game exe was not responding (no authorization requests or error messages, nothing). Update happened around february 20-21 2009.

I reinstalled the game and the problem was not solved, so i checked on another computer and the same problem showed (previously the game was working fine on both computers). I figured out it was maybe a firewall issue and disabled the whole suit, still not working. So i tried to UNISTALL completely comodo and the game started to work again.

Before you ask, let me say that unless there’s a new setting “on by default” with the update, the problem can’t be caused by a wrong comodo setting, cause the game was working perfectly before the update. I checked on 2 computers and both behaved the same way: the game stopped to work after the update, and started to work again only after the unistallation of comodo.

Hope you can find a solution or fix the problem, cause i like comodo.

I only use Comodo for the firewall and keep defense plus disabled. I WAS having the same trouble with supreme commander not loading. I found a solution besides uninstalling completely, and as i dont use defense plus anyway, this is perfect for me. You can set a “disable defense plus permantly option”, which requires a reboot. Under Comodo, hit the defense plus button in top right, then advanced on the left. Then hit the defense+ settings option on the right section. Under the default tab, general settings, you will see a check box at the bottom for disabled defense+ permantly. Then you reboot when prompted and you are good to go!

All this is good if you don’t take the time to let Def+ recognize all the executables, after you make them ‘Trusted Aplication’ on both the Fireall and Def+ you shouldn’t have any troubles. You can also add the execs manually from Def+. A Windows restart is advisable after this if the game doesn’t play right.

If you grant all exes ‘Trusted App’ security lvl you don’t have any problems, looks like CIS is not recognizing well all the exes of the game. Take a look in ‘Advanced’ → ‘Computer Security Policy’, double click on ‘Application Name’ to wrap them and see more easily the security policies associated with them, locate your game.

Good luck.

Welcome to the Forum, Guys.

Will placing the firewall and D+ in training mode (will create the necessary rules) help any in allowing the game to run?

Hi, I have had the same problem as the two previous users. After searching a bit I found the solution proposed by styxdogg which solves it for me too.

This is not a problem caused by inappropriate security policy: the exe(ForgedAlliance.exe) is a “trusted application” in my policy and it does not launch any other exe.

Besides, the problem occurs somewhat randomly (roughly 80% of the time). The exe appears to be launched normally but dies almost immediately.

I have monitored the execution with procmon (log available if you want, although there is not much information concerning the error) and it dies always at the same point while trying to create a new thread. More precisely, the error appears to be a “C++ runtime error R6016 - not enough space for thread data”. However, it does not always show that error message: most of the time (99%), it just dies without notice.

In case this might help, the same symptoms have been observed by users not using COMODO but having a specific Logitech dll (LVPrcInj.dll). It appears that the dll was injecting some code in the application (or something like that) which for some reason caused the bug. Since Def+ is naturally intrusive I would not be very surprised if the problems were very similar.

Following that idea, I have tried to disable some of the SSDT hooks related to Def+ (cmdguard.sys). I could apparently disable all of them using IceSword (except the one on NtOpenProcess) but it did not change anything to the problem.

I hope that someone can investigate this issue further and fix it in a future version of COMODO, because I really like Def+. It has admittedly annoyed me quite a lot but also definitely prevented many malicious programs to infest my comp.

Same problem here :frowning:

styxdogg solution was the only one which would allow FA to run again. For me however (Vista Ultimate 64), the EXE would always die the same way - Access Violation (xC00…5) and always the same code adress as well (looks like ntdll.dll).

Shutting down Comodo fully didn’t help either, to my surprise…
Adding to trusted application also didn’t help…

It really required styxdogg solution: completely disabling D+ which I do find quite “extreme”…

I hope you guys can find the bug or a workaround in D+ - because I doubt THQ will issue an update due to Comodo :wink:

Hi, same problem here!

Completely disable Def+ worked for me quite well, thx to styxdogg! Setting ForgedAlliance.exe to trusted application didnt.

After clicking around a bit the following steps allowed me to start Forged Alliance without completely disable Def+:

Forged Alliance is set to trusted application. Starting Forged Alliance always skips with no error message at all.
But if i open “Comodo Firewall → Defense+ → View active Process List” there appear some different errors:

1st - skip with no error
2nd - drwtsn32.exe says program error
- drwtsn32.log shows an error:

*** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\WINDOWS\system32\ntdll.dll -
Funktion: ntdll!KiFastSystemCallRet
*** ERROR: Module load completed but symbols could not be loaded for C:\WINDOWS\system32\guard32.dll
7c91e4da e829000000 call ntdll!RtlRaiseException (7c91e508)
7c91e4df 8b0424 mov eax,[esp]
7c91e4e2 8be5 mov esp,ebp
7c91e4e4 5d pop ebp
7c91e4e5 c3 ret
7c91e4e6 8da42400000000 lea esp,[esp]
7c91e4ed 8d4900 lea ecx,[ecx]
7c91e4f0 8bd4 mov edx,esp
7c91e4f2 0f34 sysenter
FEHLER ->ntdll!KiFastSystemCallRet:
7c91e4f4 c3 ret
7c91e4f5 8da42400000000 lea esp,[esp]
7c91e4fc 8d642400 lea esp,[esp]
7c91e500 8d542408 lea edx,[esp+0x8]
7c91e504 cd2e int 2e
7c91e506 c3 ret
7c91e507 90 nop
7c91e508 55 push ebp
7c91e509 8bec mov ebp,esp

3rd - the C++ runtime errorJoeDalton mentioned

The errors seem to appear at random, sometimes all three, sometimes only the second…

The funny thing is that Viewing the active process list and starting the ForgedAlliance.exe (several times, sometimes just doubleclicking the exe alot) allows me to start Forged Alliance (after some errors). Once it started i can exit and start it again with no problems (sometimes i have to doubleclick the exe several times, but no error messages appear). !!!But only if i have the ´View active process list´ opened first and some errors appeared!!!

Strange thing, but maybe it helps to fix the problem.

I have the same problem and just like to add that the original Supreme Commander game doesn’t have this problem. I have both games and the original works fine.
Just a FYI for the mod, it’s 2 separate games but I think the Forged Alliance only has slight engine modifications, which aparently crashes the game with Comodo.

I also have the same issue. Running Vista 64 on a new rig (Quad Core w/ 4 gigs of RAM).

SC original game works, FA crashes when Defense+ is enabled.

Manually adding the .exe file does not fix this issue. You continue to get the c…00005 error upon execution of the game exe.

Disabling Defense+ and rebooting fixes it. For now I’ll just change settings when I want to play.

Commodo Dev Team- any status on whether this will be addressed in a future patch/version? FA is not going to be updated (I think the last game patch was about a year ago).

I’ve also had weird oddities with the RAM Firewall utility- to the point where I just uninstalled. I love the protection schemes, just hope that we can get this particular one resolved some way other than a workaround on the client side.


Hey guys. I have one simple suggestion: submit that .exe file to analysis and maybe it will be ignored on future updates of CIS. I know how hard security products affect gamers some times, unwillingly of course.

now the problem is solved by the last update today.