Support for Ubuntu 16.04+

Hi Comodo Team,

Comodo antivirus is an excellent product. Unfortunately it does not have up-to-date support for Ubuntu recent versions. Can we expect a Ubuntu 16.04 compatible antivirus installer please? Current installer fails to install on Ubuntu 16.04. Had to follow these steps - Ubuntu Forums to install it forcefully. It would be better if we have out of the box support for Ubuntu.

I am unable to view the information at that particular link, even after registering. Can somebody post those steps?

Comodo is working CAVL:

Stay tuned for more.

I tried to install from the .deb file, with no luck. anidotnet stated there is a procedure to force the install. I need those steps, because the link provided in his post is not working for me.

Does the procedure from Filesystem Filter Driver for kernel 3.5-3.18(redirfs and avflt) still work?

Unfortunately, the installer won’t even execute in 16.04. It may in 14.04, but I upgraded not too long ago.

Hi. I researched in the Ubuntu users forum before generating a new forum topic:

If anyone is actively researching or finds a resolve, update the forum and I’ll update the post in the Ubuntu forum topic. The topic has the info such as ubuntu error report #, XML diagnostic that the CAVL program generated, and the last part of the installation commands at the CLI.

Only the 32bit version will install on latest Ubuntu and Ubuntu based distros but after install and running, there will be a error about a filesystem driver. I have not tried the filesystem driver fix.

Understood. Just wanted to check before reverting back to 14LTS.

Not Working in Ubuntu 16.04 x64 old library libssl 0.9.8

lsb_release -a

Distributor ID: LinuxMint
Description: Linux Mint 18.1 Serena
Release: 18.1
Codename: serena

wget -c

dpkg -i cav-linux_x64.deb

The select package previously selected cav-linux.
(Reading database … 229206 files and directories currently installed.)
Preparing to unpack cav-linux_1.1.268025-1_amd64.deb …
The unpack cav-linux (1.1.268025-1).
dpkg: problems with dependencies prevent the setting of cav-linux:
CAV-linux depends on libssl 0.9.8 (> = 0.9.8 m-1); However:
Libssl package 0.9.8 is not installed.

dpkg: error processing the cav-linux package (–install):
dependency problems-leaving unconfigured
Errors were encountered while processing:

apt search libssl

i libssl1.0.0 - Secure Sockets Layer toolkit - shared libr
i libssl1.0.0:i386 - Secure Sockets Layer toolkit - shared libr
p libssl1.0.0-dbg - Secure Sockets Layer toolkit - debug infor
p libssl1.0.0-dbg:i386 - Secure Sockets Layer toolkit - debug infor
v libssl1.0.0:i386 -

just download the lib from Ubuntu’s Package Center

This is not a normal behaviour. My experiments are here - Comodo Antivirus in Linux - - no success with real-time protection.

Found no new answers to this question. Installed CAVL on Ubuntu 17.10 (Lubuntu) but File System Drivers were not installed. Error report was ¨Build the RedirFS kernel modules for real-time protection¨ but neither redirfs nor avflt could be found in the latest kernel update Linux 4.13.0-38-generic.
Any other solutions?


[at]Comodo-Dev-Team: I very much appreciate the effort put into building CAV for Linux.
This has always been my favorite security company, and will now continue to be unless quality goes down the drain.

but unfortunately, the installer fails on Xubuntu 16.04 with:

I understand others have been having this issue, and the fix apparently seems to be to download and install the lib manually:

but the deb could do this for us as well, and is something that needs to be fixed as I’ll be installing on multiple machines throughout my network.
some machines even require Ubuntu 12.04 (x86) to use the properly functioning nvidia-96 driver (nouveau sucks)

Please fix as this does knock down your quality :slight_smile:

deb obtained from: 5 Best Antivirus for Linux 2022 | Linux Antivirus