Support for Terminal Services? [SOLVED]

Is there any way to enable support for Comodo’s alerts and notifications when using Remote Desktop? If I try to run a program that doesn’t already have rules or permission to run, it’s automatically blocked (I get an alert saying it’s not a valid win32 app). I don’t get a notification, mode changes for Defense+ (I tried Training and Disabled) and still had the problem. Is this by design or is it a bug?

I don’t use Remote Desktop, but I would hazard a guess it is by design.
Could one of the developers please confirm this?

Can you go to Defense+, Advanced, Computer Security Policy, and look for:


Set that to “Trusted Application” and it should be able to start.

No, no, you misunderstand. I’m remoting into a machine with Comodo. If I do anything on that remote machine that would cause Comodo to normally prompt me, that action is automatically blocked and I am not prompted.

Well, my guess would be you need to run “mstsc /console” or “mstsc /admin” depending on your RDP client version.

Then i misunderstood, you are trying to connect to a machine with CIS installed ?
On what machine do you get the “not a valid win32 app” message then ?
If you have disabled D+ i seriously doubt that it is caused by CIS.

Okay, strange. It works now. I don’t think it worked with CFP 3.0, but I’ve since upgraded to CIS. I just tested with and without the /console parameter (Which I tend to always use anyway) and it works. It may have just been a funky rule. Thanks for the help and suggestions; this can be closed now.