Still unable to update

Hi there!
I using CIS latest beta on my PC (Windows 10 with latest update) every other apps working fine but it just CIS that won’t update at all automatically or manually!! always same error, time out!! while I can ping Comodo DNS… it just won’t update with Comodo DNS or any third-party DNS even with different ISPs. :frowning:
I just able update once when I connected to a VPN server.
In this condition it’s hard to install CIS for other users as recommendation :frowning:

Not having an issue at my end (UK). Is there anything being blocked int he Comodo Logs? What firewall configuration are you using? Have you tried switching your CIS configuration to the default Internet Security?

Hi there! Comodo logs doesn’t show any blocked item, the current configuration is Proactive Security (AV not installed).
I try default configuration right now but still not updating, it’s just updating with a VPN connection.

Try uninstalling and installing again.
But before that, remove the CIS with a program that eliminates traces that are stored on the computer.
After that, just install it to see if it resolves.