stateful virusscanner locking the computer


The last few weeks I’ve been encountering the issue that after a certain amount of time (and sometimes in the middle of the night) I am unable to open any new programs (win 10) or even open task manager and the start menu. The only way to resume function was to restart the pc by longpressing the power button
During this freeze, basic function like the clock still worked, so it wasn’t a complete freeze

After a few occurences of this I had an elevated task manager started right after a reboot, and waited for the issue to reappear. When it did I started killing tasks until it would hopefully work again. After several tries I found out that by killing cmd_agent (through the main comodo running program–>analyse wait chain) in task manager, the issue was immediately fixed (all previously attempted to start programs immediately launched, as if they were waiting for something to finish)

After several more tries to comfirm that just killing cmd_agent fixed it, and an unsuccessful uninstall/reinstall of the entire CIS suite, I disabled the antivirus portion of Comodo Internet security and turned windows defender back on comodo firewall is still running

Since then I have had no more issues

So my question is: what could be causing this? I’d love to continue using the entire CIS suite instead of just its firewall.

it is not common, virusscanner not lock PC;
this can indicate problem in hardwares as HD, memory or super heating in CPU… alright check status of the your hardware?

sorry my english!

Thanks for the reply, I could understand you well enough :slight_smile:

I’ve temporarily uninstalled the virusscanner (but kept the firewall) and switched to a different one for now. Since then (3 days) no new issues)

However I did do some hardware check: HWmonitor showed no heat spikes/overloads, HD scanners revealed no issues with the main HDs
Haven’t checked the memory yet (edit: i forgot windows had a memcheck tool now) so I’ll give that a go on the next restart to be sure

It’s a weird issue, and I never had issues with Comodo like this before.