Splash/Nag (?) Screen after update to V12.2.2.7098

As the title says I get a Splash or Nag screen with the title “Comodo Install” at the top:

I’ve tried with removing and keeping the check mark, clicking on both buttons and it still come back after every reboot.

Also in the Win Task Manager there are 2 instances of Comodo Internet Security at the top of the list of processes, when opening the file location of the bottom one it takes me to:

C:\Program Files\COMODO\COMODO Internet Security

and it points to a file called “cmdinstall.exe”

I’ve had this screen show up in the past after an update but clicking “Skip” would get rid of it, not this time. My questions are:

  1. Is there a way to get rid of the screen?

And if not

  1. Can I rename cmdinstall.exe to something like cmdinstall.exe.sav or completely delete it and will affect the working of all the other components of Comodo?

If it matters:

Windows 10-64 Bit, V20H2 Build 19042.685 all patches installed
Intel Core i5-10210
8 Gb Ram
500 Gb SSD 320 Gb free.

Many thanks in advance.

Just untick the box and click on "Skip"and you won’t see it again.

Yeah, no, that does NOT work! It worked in the past but now it doesn’t, I believe I stated that in the original post.

And I tried all 4 combinations, both buttons, checked and unchecked. It… Does… NOT… Go… Away…

Hi ArgosDex,

Thank you for reporting. We have tested it, the screen that you have mentioned appeared only once. Once after uncheck and skip it doesn’t appeared again even after restart.

We have reported your issue to the developers, they will check this. Could you please try clean install once.

Sorry in the delay getting back. As you suggested I uninstalled Comodo and ran ciscelauptool from safe mode and did a clean install with a newly downloaded installer an up to now the splash screen has not showed up again.

Thanks for the input but I was hoping for a solution without a reinstall.