Sorting columns in Application System Activity Control window messes up GUI[NBZ]

The bug/issue

  1. What you did: Tried to sort the permissions in the Defense+ Application System Activity Control window (ONLY in Customize mode)
  2. What actually happened or you actually saw: The “Modify(/” does NOT open the window mentioned by its item.
  3. What you expected to happen or see: the Modify link should open the related setting.
  4. How you tried to fix it & what happened: Resort the items to their normal position.
  5. If its an application compatibility problem have you tried the application fixes?: n/a, it’s CIS GUI.
  6. Details (exact version) of any application involved with download link: n/a
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Open whatever app it’s been set to use Custom Policy, then Customize, then try to sort the “Modify” column.
  8. Any other information (eg your guess regarding the cause, with reasons): According to my tests, it seems that the order of the items is hardcoded in the program; however, it allows the user to sort them in a different order. So, when you click on Modify, it will open the item it refers to when there are no sort options applied.

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: I decided to make two small videos with SnagIt 10 to show you. It was a bit buggy (windows opening and instantly being hidden) but the bug can be clearly seen if you follow the cursor. (Codec: XviD)
  2. Screenshots of related event logs and the active processes list: n/a
  3. A CIS config report or file. n/a
  4. Crash or freeze dump file: n/a

Your set-up

  1. CIS version, AV database version & configuration used: 5.0.162636.1135, Comodo Proactive Security
  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?: CIS v4, and no.
  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?: Imported the old configuration straight from CIS v4 (Proactive Security).
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here. ) Full protection (interprocess memory access, process termination, etc) on CIS process. Only Windows DLLs, Process Explorer and Avast can access CIS.
  5. Defense+ and Sandbox OR Firewall security level: Proactive Security, enabled, Custom Policy mode.
  6. OS version, service pack, no of bits, UAC setting, & account type: Windows 7 Home Basic fully updated x64, UAC on with no exclusions or auto-elevation policies.
  7. Other security and utility software running: Avast! 5 free, MBAM 1.46 registered version.
  8. Virtual machine used (Please do NOT use Virtual box): None.

[attachment deleted by admin]

Thanks you for doing the bug report in standard format, before I move to Format verified Issue Reports - CIS

Would you please consider importing a standard configuration from the Comodo CIS folder to see if this will fix the problem.

If you do please export your current configuration first in case of problems.

When you import the Proactive configuration please make sure you choose a different name like Proactive1 (if you choose the same name it will overwrite that configuration without warning), then activated the new configuration.

Thank you

I just grabbed the original Proactive Security configuration file and activated it.
I can still repro the issue.
(Video attached to show how I reproduced the bug again)

[attachment deleted by admin]

Thanks moving now.


Making the same test, indeed the sorting action only moves the first column, but not the others (i.e. all the other columns keep their original order, including the last “exclusions” one with the “modify” link).

I am afraid that the same behavior exists in all other sorting windows, and e.g. the viewing of virus events shows the same: when i open it, the first item has the flags “ignore” and “succeeded”, while the last one respectively has "“detect” and “succeeded”.
After sorting, the last item becomes the first one, but keeps the flags of the former first one.

Thanks for the Video did not quite understand what you meant :slight_smile:

Once you click on the Exclusions Header all the columns are not what they seem clicked on Modify for Processes Terminations and got Protected COM Interfaces.

Thanks again

[attachment deleted by admin]