something that irritates

:-\ I programming something in the visual C and I often generate new exe file with same name and comodo persistently put it in the unricognized files and limits it even I put it again and again in the trusted files, sometimes I get system blocked and loosing typed code, specially irritates when I put something in the trusted files I get it again and again in the sandbox ??

on the contrary, my concern was that CIS always trusts executables I compiled. (without confirmation)
my case occured when executing IDEs with administrator privileges with UAC enabled system.

do you know how make digital signature? may that will help.


CIS puts it inside the Sandbox again and again, because every recompile changes your programs binary structure, even if you don’t change much or nothing at all.

( This is due to compilers being complex software that try to optimise your program each time you compile it for better speed, memory usage and more, also there is a difference between debug and final build as the debug build contains a lot of information which helps the integrated debugger to catch certain exceptions like a division by zero and so on. So the program will look different each time when comparing it with previous builds )

And because the recalculated Checksum for your Program doesn’t match the old one saved inside trusted files, CIS will do what it has to do and sandbox it because it is unknown. This is, although annoying, correct CIS Behaviour.

You can potentially solve it by adding the entire IDE to your Trusted Files and the Folder which contains your written Programs (the working folder which contains every file associated with the project like code). So CIS will not check these for changes I think.

Maybe you can get around this by using “Image Execution” exclusions. Try excluding the folder where the files are and see if they still get sandboxed.

Disable Sandbox and set D+ on training while you program/write code… :-TU

I’ve run into the same thing. Comodo really needs to address this type of application…

There’s a fairly easy, although counter-intuitive workaround.

Go to Defense+ → Computer Security Policy, and Add the application you’re developing. Give it the Installer or Updater predefined security policy. Now it will no longer get sandboxed with each new compilation.

:-TD nothing helps.

The method I stated will work.