[solved] winxp sp2 windows firewall won't shut off [RESOLVED]

I recently installed Comodo 3 on my new laptop. I have WinXP sp2, and the Comodo install seemed to be fine. I set Firewall to Safe Mode and Defense to Clean PC mode so I wouldn’t get an overwhelming number of prompts.

In the Windows control panel Security Center settings, it said that “at least one firewall was on”. I looked at the Windows Firewall settings, and saw that it was still on. I turned it off, and then the Security said that “Comodo Firewall was on”. I thought I was done.

Then upon reboot, I found that the Windows Firewall was on again! I read the FAQ here about having the Windows firewall on at the same time as Comodo. Some said that it was OK to have both on. Others said that Windows Firewall should be shut off.

I did some more reading of forums, and found ways to actually disable the Windows Firewall altogether by stopping services. I tried that, and that did prevent it from going back on, but then I found that apparently File Sharing and some networking was gone.

That basically leaves me with 2 questions.
Should I care that Windows Firewall remains on?

Do any of you know why Windows Firewall will not shut off and stay off?

Thanks very much!

Windows firewall shouldn’t restart once its off. You can try rebuilding the repository folder. Go to run and type “services.msc”. Go to the WMI service (Windows Management Instrumentation) and stop it. Then go to C:\Windows\System32\Wbem and delete the repository folder. Then reboot. Be sure to turn off Windows Firewall again before doing this.

Thanks very much for that fast reply. That sounded like a great idea, and I just tried it, but upon reboot the $%#$% Windows Firewall was back on. Amazingly hard to kill, I guess. Any other ideas?

Thanks again!

Have you Googled “Windows Firewall Wont Shut Off”. This topic will be moved I am sure cause its not a Comodo problem. Unless you try completely uninstalling Comodo and then try to disable Windows Firewall. Reboot 3 or 4 times to see if it turns back on by itself.

I did try Googling everything I could think of before asking. Thanks for the help. Yes, maybe something else is causing the problem. I guess my next step is to comb through everything that loads when Windows starts.

I appreciate the ideas. Thanks.

Did you read that link I sent you? Did you do what was suggested in that forum?

I would start from scratch since we can’t be sure of how did you leave the different settings after all your tries. Go to “start > control panel > Windows firewall”, and disable it (you need admin rights of course). No need to disable the service, and it’s also needed for shared access as you’ve seen. Then delete the repository (C:\WINDOWS\system32\wbem\Repository) and reboot.

After some further research, I found the answer. Among the zillions of TSR’s that start with Windows, a setting buried in a network management program was turning the Windows Firewall back on. Most annoying, though I’m sure well-intended. Once that was off, Windows Firewall did not re-enable itself.

So there’s really no way you could have known that. Thanks again for your help!

This thread is now closed.

If you need this thread re-opened, Please PM any online Moderator.