[Solved] PrivDog is not installing automatically into CID or FF with Windows 7.

Windows 7 32-bit.
PrivDog V1.1.0.72 is not automatically installing into IceDragon V22.0.0.1 or Firefox V22.

Note: This issue is not present with my Vista 32-bit.

My workaround posted in reply 79 in the link below does appear to work correctly.
PrivDog &AadBlock

thank you for your message. it’s important for us

I tested PrivDogSetup_1.1.0.72_signed.exe in Windows7x32.
I have two scenarios. But the plugin is installed in FF and IceDragon correctly.
I use v22.0(FF) and v22.0.0.1( IceDragon)

  1. Install the setup
  2. Open all browsers
  3. go to the “Add-once” in FF and IceDragon

1.open all browsers
2.Install the setup
3.close all browsers
4. wait about 30-40 sec
4.open all browsers
5. go to the “Add-once” in FF and IceDragon

if I Install in silent mode the plugin is present in FF and IceDragon also.

Can you reproduce it ?
Can you write all steps?

thank you!

Hi NPoberezhnaya,

  1. Download PrivDog from here, to the downloads folder.
  2. Close all browsers.
  3. Navigate to the installer and run the installer, leaving recommended settings during install.
  4. Select finish when installation is complete and close the downloads folder.
  5. Open FF and CID and open the add-ons, extensions and PrivDog is not present.

This does appear to be system specific, because following the same steps with my Vista and XP systems the PrivDog extension installs correctly for both FF and CID.

I will keep you informed if I find out anything else.

Thank you.

Hi Hi NPoberezhnaya,
Update on this issue.
Creating new user profiles for both FF and CID, then re-installed PrivDog and it installed correctly. :-TU

I am not sure what corruption/conflict was in the old profiles, but for now it is solved for me.
My guess is maybe an old add-on that didn’t remove totally.

Sorry to have used up your time and thanks from Captainsticks.