[SOLVED] No inbound connections and all ports closed (v3.9.95478.509 X32)

  1. P4 HT Prescott 3.0 Ghz
  2. WinXP 32-bit SP3
  3. I uninstalled v3.8 X32 and installed v3.9.95478.509 X32 following all regular steps.
  4. I ultimately added: [IP] in From [IP] Any to [Local Area Network #1] Any where protocol is Any, to Global Rules and the following applications: svchost.exe, Windows Operating System & System. Also set utorrent as a Trusted Application which says I have no incoming connections and probably is a network problem, my torrents are slow uploading/downloading, ‘utorrent’ has a default port test that show the listening port is closed (http://www.utorrent.com/testport.php?port=14240), besides that I can use the Internet normally but slow. In the ‘Active Connections Panel’ you can see that the source connections are all my IP ( Only my PC is connected to the ADSL MODEM.

I’d suggest to add a Stealth PortControl button to open a panel to configure it, in which you’d see how and how many Ports are Stealth and which are open. As far as I can see all my ports (0-65535) are closed/stealth and I can’t find a way to open any of them, thank you.

Best Regards.

[attachment deleted by admin]

Moved it to the Help board.

Can you show us your Global Rules as well as the rules you use for uTorrent?

Please check the Archive.7z: has the report and a scren shot of the utorrent website showing the blocked port (14240).

In this case you would need a general rule for outgoing traffic. Allow IP Out From IP Any to IP Any where Protocol is Any. Add this rule to your Global Rules and see if that helps.

When it helps you need take out the Alllow IP In From IP Any… to a specific rule for the uTorrent port of course. Your test rule leaves the Firewall out of order; it will let in anything.

I wrote “ultimately” as in last resort, because I tried MANY Global and App. rules including leaving the All Out rule, nothing worked.

When it helps you need take out the Alllow IP In From IP Any... to a specific rule for the uTorrent port of course. Your test rule leaves the Firewall out of order; it will let in anything.

I know, that is why I, as you can see, disabled them for the App Panel, but they were enabled when I did the tests.

The situation was exasperating so I restored an old C: image where I have installed cfp v3.5 and works OK, I’m attaching the successful tests.

To have greater success probability I’ll update directly from this version, without uninstalling, just letting CFP update itself from the Internet, I’ll post the results alter, wish me luck :slight_smile:

[attachment deleted by admin]

Problem solved. I’m including the Screen Shots of success tests.

The problems seemed to be WinXP, that was damaged somehow.

The image of C: I restored was WinXP after a clean install and installed only programs I use, then cleaned the Registry(NTREGOPT) and Defragged (PerfectDisk 10). I C: I only have WinXP and programs, everything else is on other partitions (all temp files(WinXP ¡, browsers, Java), My Documents, Page File(pagefile.sys)).

I forgot to mention that I tried the following to solve the problem before the image restoration:

  1. CHKDSK All units.
  2. I tried to restore the WinXP Registry with May 22 ERUNT AutoBackup
  3. Tried to clean the registry with the COMODO System Cleaner, a tool I discovered yesterday :slight_smile:
  4. I tried to clean the Registry with NTREGOPT (http://www.larshederer.homepage.t-online.de/erunt/)

Nothing worked, somehow along usage and installing/uninstalling programs WinXP got screwed up and I really don’t know how, I install only what I need and test some programs once in a while, well 1 more WinXP mystery unsolved.

As a side note COMODO Memory Firewall, had a red message at the bottom of its window saying something like “Driver is not working, please reinstall the product” and whe I tried to uninstall it the Installer gave a typical WinXP error window, I re-downloaded it, checked the MD5 checksum, was OK, installed itfine but after reboot the same message and after another uninstall and reboot I tried to reinstall but again the same message.

I have included the Report again so you can check my CIS config (CIS_Report.7z) if you want.

I had to leave on ‘Global’ and ‘Windows Operating System’ 'Allow IP From [IP] Any to [Local Area Network #1] Where Protocol is Any, so utorrent can have its inbounds and have a complete communication among peers and to avoid having blocked hosts, I know is risky but is effective and necessary for torrenting. When I don’t use utorrent I slide down so it can be disabled.

Since utorrent is set as a ‘Trusted Application’ and still I need to set the ‘All In’ Global and OS rules obviously this is a CIS limitation and not an error in my config.

Best Regards.

[attachment deleted by admin]