[Solved] Error in Downloading signatures [merged topic]

There have been no database updates for my two computers (one Vista and the other Windows 10 1709) since upgrading CIS from to the current version in response to a program upgrade notification a few days ago. The database version for both computers remains at 28172.

Clicking the update button on the program would produce the following error message:
Download signatures
Status: The system cannot find the file specified.

This morning, I have even uninstalled and re-installed version for my Vista. But the result remained unchanged: same database version and same error message.

Don’t know what has gone wrong. Please help.

Same problem here on Windows 10.0.16299.125 / CIS
Already tried restarting the machine and reinstalling CIS. Manual .cav installation also failed with “There is a bad version number in the file.”


I am also getting the same error, exactly as it appears in Intermezzers post.

Tried manually installing the .cav file as well via the ‘import virus database’ on the ‘About’ page, after downloading it from here; Comodo Anti Malware Database Latest Version & Additions 2022, only for it to spit back a message saying “There is a bad version number in the file” when it got to the install.

OS is Windows 10, CIS Premium 10

I dont get any error message but comodo has not updated its database in 4 days, when i click the update button it dont show any errors but neither downloads anything, simply like there is no updates available.

yesterday after I posted came a database update, now the database version is 28178; today morning i have the same error as @Librax & @intermezzer

similar issue here…

With the description it seems issue with syncing of one of files on some download servers.

We are investigating it.


Could the people suffering try the following procedure and see if it helps:

Unfortunately doing this didn’t help (at least for me).

I am also getting the same error, exactly as it appears in Intermezzers post.

I tried to locate the base file but nothing there!



Nothing else in those folders!

Same problem here, using the update function fails on “Download Signatures. Status: The System cannot find the specified file.” Downloaded bases.cav version 28197 and tried manual import. Got “There is a bad version number in the file.” (This is after uninstalling and reinstalling CIS earlier as I was getting errors with Websites Database updates.) Ran Diagnostics and got no errors.

You need to look a bit deeper I did wonder if this had changed as it was a much earlier version of CIS, screenshot below of correct updates during update process which all disappear after update has finished.


Of course, I looked deeper i checked every folder nothing there!

Thank you!
that worked for me! :smiley:

On that directory there is only one file in \certupd\authroot.stl, the other directories are empty.

the only .cav files in my pc are in \Program Files\COMODO\COMODO Internet security\scanners

It didn’t work for me. Same result as in the cuyo01 post.

I have one notebook and one desktop, both can’t update the new virus signatures since yesterday.
Other update were fine.

Sometimes a stuck update can be fixed by following Dennis2’s procedure. When that doesn’t help that may indicate the problem is not on your computer but server side. Umesh is looking at the server side of the update process.

At fhkh. I merged your topic with an already existing topic.

I had the same experience empty folder…

Same exact problem,

Also i didn’t find any .cav files located in ProgramData, empty folder., and yes i already set the view to “Show Hidden”, nothing there.

Already try clean Uninstall then restart, reinstall- restart again, same problem appear.

Hopefully it’s server side and can be resolved soon.

Hi Guys,
We hope to solve it today. We are working with CDN providers to isolate faulty servers.