[Solved] d3dx9_43.dll error a fix found but why.

I was receiving the attached error, copying the named file from the Firefox folder to the Dragon folder in the Program files folder fixed it but what is it and why was this necessary??


[attachment deleted by admin]

I can only guess.

This looks like a Direct X file to me. And since not all users have their Direct X updated to the latest available version I guess that the Chrome devs decided to use a version they need.

Now the plot thickens. On my Win 7 there is no such file in the Dragon installation folder but it is in the System32 folder; I have the latest Direct X of June 2010 installed.

May be updating Direct X will also do the trick. Get it from Filehippo for example: Download DirectX 9.29.1974.1 for Windows - Filehippo.com .

EricJH the link you provided has older dx 9 update.

Here is the newest dx 9 runtime:
Date published: 4/18/2011

Howdy Leon. Thanks for the link.

I first thought Filehippo was outdated.That does not happen often but it is not impossible. Upon further inspection that article also provides the Direct X from June 2010. Microsoft apparently only updated the article… :wink:

Well i am here frequently but don’t write much.
One step at a time with my red dancing shoes on. ;D

Hi Guys,
Thanks for the info and links.
I forgot to mention it only happens with particular sites.
I haven’t installed yet but I will and see what happens.
It was more curiousity than anything to what was happening.
It just puzzled me a bit as to why only Dragon, all is good thanks.

The example you sent me uses Flash. That may need a more recent Direct X for hardware acceleration. Just thinking out loud here.

I have seen the same issue on 14.0 and 14.1 on some sites…

Is your Direct X up to date? The d3dx9_43.dll is from 2010 and must be part of Direct X June 2010 package.

Do you have some url’s to test?

Only 2 places are \Program Files (x86)\Firefox and Thunderbird as a packed application extension.
So it seems to be left out the installer for CD. Version 9.29.952.3111

Hi Guys,
This is getting strange, the named file comes packed with Firefox.
If I copy it to Dragons program folder or the system 32 folder the result is the error is gone.

I was presuming it was an error for Product V9, not the file version and I always thought DirectX had backwards compatability and my version is V11 (File version 6.01.7600.16385).
I realise this isn’t the latest for V11.

File versions and product versions are a bit confusing IMO. Here.


Edit: No errors using XP with Dragon with the same site.
DirectX V9 (File version 5.03.2600.2180).

Edit: Curiousity has a way of taking control :).

I just got the same error going to apple’s website and clicking the mac section.

I have directx version 11 and file version 6.01.7601.17514.

edit: did the same thing you did and copied the file from firefox folder to dragon’s and the error went away.

Hi Syk69,
Apple also does it with mine without that file in Dragons folder. Mac - Apple (AU)

Has anyone else tried this in other chromium browsers?



We’ve found the problem and it will be fixed in the next releases.

Thank you for your support!

Thanks Mihai Vasilache for looking into this, from Captainsticks.

Great :-TU

This occurs because you don’t have DirectX installed, even if you copy a .dll file to the system32 directory, dragon will tell you there is another error.
The solution is install the DirectX full package and all will be fine

Thanks everyone for your input.

Thanks Mihai Vasilache I can confirm this has been corrected in the latest release V14.2 Thanks.