[SOLVED]Comodo Secure Shopping Service is not running.


I’m trying to run Comodo Secure Shopping but each time I try I get the message Comodo Secure Shopping Service is not running.
I had this problem before but normally restarting the computer fixed the problem but not this time.
I’m unable to launch it for 2 days now, I guess it won’t fix itself this time.

Is there anything I can try other than reinstalling Comodo Secure Shopping or Internet Security?


Hi ddabrahim,
Team will be in touch.
However we have RC version ready to go live next week, it has updated “Comodo Secure Shopping” module with some code changes related to service.


Hi ddabrahim,

Could you please kindly let me know which Comodo Secure Shopping you are using? What OS is it on your machine? Is the csssrv running on your machine(Refer to sreenshot for detail). Please
start the service and tried if it is not running. Is there any antivirus software installed on your machine? Please provide the name and version of the antivirus software if you do.


Sorry for the late reply.
csssrv is not running, if I try to run it manually it is not responding.

Windows 10 Pro 64bit version 1803 build 17134.112
Comodo Internet Security Premium 10 version:

I don’t know the secure shopping version can’t find any info on that, it was included with CIS and have been update (if ever) along with it I’m guessing.
I don’t have any other antivirus installed but Comodo.

Thank you.

If you go to control panel and then programs and features, you should see an entry for CSS and look under the version column to see the version number. Do you have memory integrity enabled?

Hi ddabrahim,

Did you enable csssrv via the following UI?

You mentioned “not responding” below, does it mean the screen was freezed? Did you see any error message?

Thank you


I needed to run csssrv as administrator. I got csssrv running now and secure shopping is working :slight_smile:

Thank you for your help!