[SOLVED] Comodo & Eclipse: Failed to create the Java Virtual Machine

Dell D531. (I’ve also encountered it on other machines too)
Fresh install of Windows XP 32-bit (Thus, none of the software mentioned here will be 64-bit)
Latest download and install of Eclipse Developer EE (3.6.1)

Run Eclipse: No problems.

Install latest version of Comodo Firewall. (cfw_installer_x86.exe ver. 5.3.174622.1216)

Run Eclipse: No problems.

Modify Eclipse.ini to set -Xmx###m from 512 to anything above 736
Save the file
Start Eclipse.exe:

“Failed to create the Java Virtual Machine”

Start Eclipsec.exe:

“Error occurred during initialization of VM”
“Could not reserve enough space for object heap”

I can disable every single bit of Comodo (Defense+ permanent, Sandbox Disabled, Firewall Disabled) and will still have the above problems. (Though, from my experience, ‘turning off’ anything in Comodo seems to do very little. The rules still seem to apply for many things.)

Uninstall Comodo; run Eclipse.exe: No problems.

Why is Comodo preventing me from creating a large JVM? I’m developing a java application that works with large databases and need several gigs of heap space. How do I resolve this?

Setting it as a “Trusted” application doesn’t seem to work. It doesn’t even seem to accept it, as it won’t set it as trusted without the exe being “signed”.

Is there any way to make Comodo just act like a firewall? I’d rather it didn’t monitor applications and memory footprints.

(I did a search about this but didn’t turn up any real answers. Placed it in this forum as it seems it would be outside “Firewall” part of the program if it’s monitoring applications and memory size.)
It seems linked to this same problem: http://forums.Comodo.com/bug-reports/imagej-java-virtual-machine-launcher-could-not-start-x32-3014276-t18075.0.html
But that forum post is from years ago, regarding Comodo Firewall version 3.0. Has this been a problem since then, or has it simply returned?
This link: https://forums.Comodo.com/empty-t49144.0.html
is from only a month ago, so it would seem to support that this bug has just again cropped up.

I appreciate any and all help with this issue.

Edited: Update: I was running 5.0.16 on another machine with no issues. Version 5.3.174622.1216 has this issue. I’m starting to wonder if this isn’t actually a bug.

Check if you have any events recorded in the logs that are pointing to the Eclipse and let us know what type is it (eg. Access Memory, Block File, etc.).

Unfortunately I’d checked that as well. (Sorry I forgot to mention it.)

Apart from CIS scanning the file (Scanned Online and Found Safe) and then permitting it to access the network for updates, Comodo professes to no interference with the program.

It’s rather frustrating that it claims to not be manipulating the JVM environment, yet uninstalling the program entirely and rebooting resumes normal function.

Hey and warm welcome to Comodo forums FoxKeegan:)

try to add the exe file in detec shellcode injections and this is how you do it: CIS —> Defense+ —> Defense+ Settings —> Execution control Settings —> Detect shellcode injections (i.e. Buffer overflow protection) —> Exclusions —> Add —> Browse…

I hope this will help.

Enjoy your stay here at Comodo forums and have a nice day! :slight_smile:

Valentin N

I’ll reinstall 5.3.17 shortly. As it now stands I have tested and resolved my issue.

I had one machine that functioned correctly and I couldn’t figure out what settings I’d put to have it work properly. The answer: I didn’t.

I’ve always installed Comodo Firewall from the file cfw_install_x86.exe. I wasn’t aware revision numbers weren’t included in the file name. As such, I didn’t notice that the one machine that worked was running 5.0.16, and all the ones failing were 5.3.17.

I have confirmed that the 32-bit version of 5.3.17 will not function correctly with the latest Helios version of Eclipse should you adjust the max heap value above 736 megs. The 64-bit version seems to work just fine.

Fortunately I have a saved copy of 5.0.16 in the 32-bit format on my server and installing that seems to work just fine. With luck Comodo will resolve this issue in the near future, or provide a work-around.

Additionally: Where may I download older versions of CFW on Comodo’s site?

I’ll post if I find a way to get 5.3.17 working, however given the task list I’ve already assigned myself, I’m afraid it isn’t a priority at the moment.

try with softipedia or with http://www.filehippo.com/

btw did my suggest do any good?

Valentin N