SMTP information incorrect, but it isn't....

Hi there,


I recently came across Comodo AntiSpam- I have antivirus and firewall. The version is 2.6. I tried to use it a couple of weeks ago and kept getting the screen that my smtp information was incorrect so I uninstalled it. I decided to give it another try as the alternative is driving me crazy and it worked fine for the first few hours, but sure enough it started again :o , first a screen saying -

Your outbound sever is not responding to the following accounts …

and when I click ok the outgoing mail window appears- I have tried with and without my email username and password but the same happens either way. All of the information is correct, as I said, it worked fine for a few hours and I never have trouble with this email. Is there anything I can try to resolve this?

Who do you get your e-mail through?
Service providers usually have more than one way to retrieve mail (POP, POP3, IMAP, SMTP).
Besides that, some require different levels of authentication (SSL,TLS).

Once I have your e-mail service provider,
I will be able to give you more ideas on what is wrong.

I’m having the exact same problem. Everything worked fine the first day, but now that window keeps popping up saying the smtp info is incorrect. The email provider is and I’m receiving the mail by pop3 through Outlook Express 6.

I uninstalled CAS and reinstalled it. Everything worked fine until it detected a mail as spam and quarantined it. After that, the message keeps coming up saying that the smtp info is incorrect. It seems that everything works fine until the program actually does what it’s supposed to do, then it goes haywire.

Hi all, have just started using CAS and am having to same problem. I have CIS installed and have double checked all my settings.
Am using Outlook 2003, along with Vista Home premium.
My ISP in AUS is TPG. Any ideas.
Thanks for the great products.

Hi All,

You might be getting the SMTP popup because the timeout length in CAS is to short. I usually set mine to about 1:30 (one minute, thirty seconds). You might also try using port 587 instead of 25 but it should be only a “timeout” issue.

There is work of a new version to be released quite soon (waiting to hear back from the devs).


I doubt if it’s a timeout issue since everything works fine until CAS classifies something as spam and then the popup immediately comes up.

I’d try what Eric suggests anyway, as CAS behavoir changes when something is classified as spam. Maybe also try 5 mins in both email client and CAS if its an SSL connection. I also set automatically update settings to ‘off’, and save messages on server to ‘off’.

I note that you have Vista a) do CAS32.exe & CASproc.exe have sufficient privileges 2) are you using a power saving mode (if so try with it off - ie with computer ‘always on’).

Note that, for an SSL connection, the correct settings are DIFFERENT in email client and CAS. This causes failure (in some cases) after first Spam mail is received in XP. For Gmail correct setttings are:

POP3 995 NOT encrypted
SMTP 465 NOT encrypted

POP3 995 YES encrypted
SMTP 465 YES encrypted

NB Outlook tries to second guess you, so double check that it has not altered the port settings when you ticked the encrypted box. (more intelli-nonsense :slight_smile:

If all else fails await next version, coming soon now we are assured…

Best wishes


Hi all, This may be a dumb question but how do i adjust the time out length in CAS.
Thanks all for all help

I don’t have Vista or Outlook. I’m using Outlook Express on XP with all the standard port settings, 110 and 25.

Email accounts, choose an account - > edit button - >advanced button ->server timeouts

Undocumented in help file!!!

Best wishes


Sorry mixing you up with someone else. Not likely to be an SSL or authority issue then.


I’d still try the timeout tric, just in case


Actually, I never get any spam mail anyway,even with the spam filter at gmx turned off, so I’m not overly concerned. I was just testing out CAS and besides the problem I encountered, I thought it was far too aggressive (like many of Comodo’s offerings) and I didn’t like the message send back part. I would probably never use the program on a regular basis. I was just providing feedback on a bug.

Well i checked the time out settings and played with the port settings all to no avail.
I’m going to still use CAS because while a hassle it is catching all my spam.
If anyone has any more suggestions i would appreciate the help.
BEST wishes to all

Well after saying yesterday i was going to put up with the intial problem i found today the program was duplicating one of my email addresses not once but hundreds of times, I have since uninstalled the program untill the update arrives. Hopefuly the bugs will be ironed out by then.
Good luck to all

This is fairly easy to avoid - see my list of work-arounds in my CAS workarounds post.


Have just had a look at TPG. Think problem may be that SMTP and POP3 server are identically named.

Think that & may work as server names instead of (They are pingable and resolve to the same IP). CAS uses the different server names to distinguish files, some of which are only created when spam mails received.

Worth a try anyway. If does not work immediately try a complete re-install to ensure all old data files are deleted. You can export whitelists, editing them to avoid the email address duplication problem as I describe in CAS work arounds

If this works please do say as it will mean we have found a new bug.


Hi Mouse1, Thanks for all your help.
I’ve done a new install and the original SMTP error message is still there.
What i should have told you is my incoming and outgoing server info is different.
Incoming is
Outgoing is
Not sure if this will be of any help.
Thanks again for your help.

I owe an apology too. The issue (of duplicating emails) you referred to is not included in my work arounds.

Here is a link to the problem report:

To solve it just export the whitelist, sort it, and remove the email addresses that cause the problem. These will be addresses that differ only by a domain suffix eg:

Where xxx and yyy are the same

Usually these are addresses added in error (eg typos), though it is just possible that you need both - hopefully not!

Re your other problem I think it is highly likely that different domains for incoming and outgoing servers could cause the problem. If I have time I will experiment. Do you have these domains recorded in different clent/CAS email accounts, or in the same account?

Pity CAS has all these bugs cos it is excellent at the job of excluding spam. Se here for my post on why its worth persisting with:

Hope this helps best wishes