Slow loading or hang of flash intensive sites in IceDragon [M169]1[v6]

FlashPlayerPlugin_11_5_502_135.exe.i just go to and watch it sandbox it automatically twice. …update your flash by the way there’s an update to flash a release NOT a beta is out now…There’s plenty of time for me to get motivated for a bug report. i saw this same behavior with 2626,39, and now 2674 i actually did fill out a bug report on this for 2639. these are different environments. and it still does it. i used to run bitdefender and firefox would lock up. see link to old bug report here.might want to play around a bit seems to go away and come back as you open and close ice dragon browser to different flash websites. i don’t and and im not going to chase how it behaves with Firefox.I just tried it on the intel pc which doesn’t have firefox either and it sandboxes flash twice also. as soon as you close the browser they leave the sandbox. some webpages hanging up with this.browser acts funny/sticky.pages struggle or don’t load at all sometimes

this is the original bug report from when i was running 2639…
scroll down a a few posts and you will see a very detailed bug report.Also read my notes below about this environment compared to the bug report.

check screen shot, killswitch log is Attached Below. haven’t been paying attention until now.
what do others get from 2674 and ice dragon with latest flash?? I don’t even have Firefox installed…
i’m a comodo ice dragon addict…

[attachment deleted by admin]

I will find time for bug fix report on this.It makes not load. it’s like like lightning when you go to playboy with the behavior blocker/auto sand box is off. but when it’s on no way. i will test firefox also too. got to have my playboy. lol ;D

Please do, we would very much appreciate a bug report on it.

Will leave this here for another day.

Best wishes


0 Summary of issue:
I am sure it’s a bug.

  1. Diagnostics report:
    File attached,Killswitch log,Defense+ log file and screenshot

  2. Full Comodo product and version:
    Comodo Internet Security 6.0.260739.2674 Fire Wall Only Installed

  3. Operating System:
    Windows 8 Pro x64

  4. Configuration:
    Configuration: Proactive
    Firewall: Enabled (safe mode)
    Defense+ HIPS: Enabled (safe mode)/Enable Enhanced Protection Mode is on
    Defense+ Behavior Blocker: Enabled (limited)
    Comdo AV: Not Installed
    Block Fragmented IP Traffice Checked
    Enable Anti Arp Spoofing checked
    Using Comodo Secure DNS settings in Network Card Dns Settings

  5. Other Software Installed
    Avast! 7 Antiviruse all updated as of today
    Super Antispyware with real time protection active/lifetime license updated a of today
    Malwarebytes free mode no realtime active
    HitMan Pro 3.7.0 build 182 free version no realtime active

  6. Step by step description to reproduce the issue:
    Install Firefox 17.01 or Ice Dragon 17.01
    start firefox go to, or (login), or a heavy flash website and you will see on the widget 2 items sandboxed. check the sand box and you find 2 FlashPlayerPlugin_11_5_502_135.exe
    most of the web page loads, then it it just hangs. does not go not responding, but webites actulaly work with flash sandboxed just very slow. the previous version of flash did this but have no logs or screens shots before the update to current version.Attcahed is diagnostic, killswitch log save,defens+ log file and screenshot.

What does this mean?
Firefox and Icedragon cannot be correctly or happly used with comodo 6 cis 2674. Expect hanging internmittent loading webpages.



[attachment deleted by admin]

CIS6 2674 Double Auto Sandboxing adobe flash player plugin.exe in Firefox and ice dragon

A. Flash Player Plugin Sandboxes twice when using Ice Dragon 17.01 or Fiefox 17.01

  1. What you did:Surfed to or tried to login to
  2. What actually happened or you actually saw: Working webpages. But VERY slow like glue.And sometimes no webpages would load at all and made me to belive I had a a network problem
  3. What you expected to happen or see:Fast webpages fully flash enabled
  4. How you tried to fix it & what happened: Disabled behavior blockerin CIS 6 and everything was fast again with no problems
  5. If its a software compatibility problem have you tried the compatibility fixes (link in format)?:
    No there is nothing else running when it occurs. And it has happened with previous flash player.
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
    Avast!7.0.1474 Free Av version, Superantispyware 5.6.1014
  7. Whether you can make the problem happen again, and if so exact steps to make it happen:Choose a browser Ice Dragon 17.01 or Firefox 17.01 and go to and watch the sandbox counter on the widget. Close the browsr and they leave the sandbox
  8. Any other information (eg your guess regarding the cause, with reasons):

B. Files appended. (Please zip unless screenshots).Screenshot, Killswitch Log, And Diagnostic
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues):

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active process list. If accessible, required for all issues:
  2. Screenshots illustrating the bug:
  3. Screenshots of related CIS event logs:
  4. A CIS config report or file.
  5. Crash or freeze dump file:
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version.

C. Your set-up

  1. CIS version, AV database version & configuration used: 6.0.260739.2674 Proactive
  2. a) Have you updated (without uninstall) from a previous version of CIS:NO
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:NO
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):Defense+ Ticked enable enhanced protection, Firewall Settings, ticked block fragmented IP Traffic, ticked enable anti-ARP spoofing. Enabled Stealth Ports
  5. Defense+, Sandbox, Firewall & AV security levels: D+= SAFE, Sandbox= partially limited, Firewall = SAFE, AV = Not Installed.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 8 x64,UAC Off, Administrator level account
  7. Other security and utility software currently installed: Superantispyware 5.6.1014, Avast!7.0.1474 Free version
  8. Other security software previously installed at any time since Windows was last installed:none
  9. Virtual machine used (Please do NOT use Virtual box):NONE, But issue occurs on two different PC”S both running Windows 8 x64 pro, UAC OFff, Administrator accounts

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Update. I tested Waterfox 16.01 64 bit and it uses what looks like the 32 bit flashplayer. CIS 6 does not sandbox the flash player plugin with waterfox 64bit. Waterfox runs fine. Very fast…so until icedrgaon and or firefox bug is fixed with the double auto sandboxing of flash player plugin i guess i will have to use waterfox.


Thanks for the update, much appreciated.


I’m having a similar problem with Firefox 17.0.1. Flash sites are extremely slow. The file
listed as an unknown file and sandboxed. If I attempt to submit it the submission fails. It appears to move to trusted files OK but shows up as unknown again. If I click the hyperliink I get a message saying Windows can’t find the file.

This bug makes flash sites unusable. Please give it a high priority. I suggest your developers look at the fact that Firefox is 32-bit and the file involved is most likely
they may be getting confused by file redirection.

THanks for the extra information, much appreciated


I’m in contact with Comodo on another bug report I filed I have sent them email asking if they have time to get to this one yet. I am ready for them…I sent email.

After closer look it’s actually Sandboxing the plugin and the plugin container process.
screenshot attached.

[attachment deleted by admin]

I can confirm having the same problem.

My system setup:

  • Windows Pro x64
  • Bitdefender Total Security 2013 (only antivirus enabled, firewall turned off)
  • CIS 6 Firewall
  • Flash v 11.5
  • Default setting

Can you confirm this is fixed in 2708, DrHaze?

We believe this problem to be resolved, because you told us so, it’s on a fix list, or we have checked and found it resolved. So I am moving it to resolved issues.

If you feel it is not resolved, now or at any time in the future, please PM an active mod who will move it back to the main board for consideration. When it is moved please add to the topic your reasons for believing it not resolved.

Best wishes