Silent install - Later versions of CIS "cis_setup_x64.msi" will not run (Error 1603)

I ran the installer for CIS v12.0.0.6882 and copied “cis_setup_x64.msi” to a folder, then ran this command in a batch file next to it. It works like it should and Comodo gets installed silently:


Directly running the MSI file of CIS v12.0.0.6882 it can be installed manually.

If I do the same with any later version like CIS v12.2.4.8032 and run its MSI file I get an error (it’s the same in Windows 7, Windows 10, Windows 11) that says this:

COMODO Antivirus Setup Wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run Setup Wizard again. Click the Finish button to exit the Setup Wizard.

Why do the older MSI files run perfectly fine but the latest one does this?

Nothing is wrong with my msiexec and the MSI file isn’t corrupt. Nothing is wrong anywhere. I can run the MSI file of and it works. Running the MSI file of doesn’t work.

If I manually install then it works, so the MSI file isn’t broken, however it’s not possible to make a silent installer by using the main installer - it has to be done using the MSI file “cis_setup_x64”.

Has anyone got a working “cis_setup_x64.msi” of the latest version

I must have spent 8 hours yesterday trying to work out why these latest MSI files don’t work if they are run directly. The error in Event Viewer is:

Windows Installer installed the product. Product Name: COMODO Antivirus. Product Version: Product Language: 1033. Manufacturer: COMODO Security Solutions Inc… Installation success or error status: 1603.

The error “1603” is meaningless and doesn’t shed light on the issue. Nothing I have tried up to now has fixed it. Most websites say stop the msiserver service in Windows, unregister it, re-register it, start the service, then register vbscript.dll… but none of that works, but then it’s not the cause - like I said I can run an older MSI of CIS and it works, but the newer ones don’t.

It’s making the creation of a silent installer totally impossible. Isn’t there a working MSI of this later version, at all? Why does the CIS installer work but the MSI inside that (when run on its own) doesn’t? The installer is obviously putting some reg settings in before it runs the MSI that makes it work?

There has to be some way to do this!

Comodo v12.2.4.8032 - Edit

I can confirm the same issue. I also tried to install it via .msi but got the same error these days. I guess this installation method is limited or prohibited since the Xcitium Client Security also can not be installed by its .msi installer.

It does install if running the exe installer (and that extracts the MSI file to a temp folder and uses that MSI file) so, if we knew what the installer was doing to make it work, it would be possible to simply add the relevant registry entries (if that’s even how it’s being done) before the MSI file is run. I have tried looking at the MSI with Orca but it’s beyond me, too complicated!

I’ll use RegistryChangesView, run the exe installer but don’t install Comodo, then take a 2nd snapshot with RegistryChangesView and see what’s what, but perhaps it doesn’t kick in until “Install” is clicked. I’ll just click install then try to quickly do the 2nd registry snapshot… because this installer adds more than 2 MB to the registry and I don’t want to have to go sifting through all that!

Edit: Doesn’t work. Adding the reg entries the installer initially puts in, doesn’t work. I can run the installer, then leave it open and run the MSI file and it still gives that 1603 error.

This is such a horrible way to automate it and it can easily go wrong if there’s a different button press to what should happen, but I did get it to be automated this way:

Get the cis installer of v12.2.4.8032 : cispro_installer.exe

This is the exact one I am using, SHA-1:

Put the installer in a folder with this batch file “install.bat”

@echo off
TITLE Comodo Internet Security v12.2.4.8032 x64
mode con: lines=20
cd /d %~dp0

echo    Installing Comodo Internet Security v12.2.4.8032 (64-Bit)
echo    Please wait until this window has closed...

:: Start main installer...
start cispro_installer.exe >nul 2>&1

:: Start AutoIt 2 script...
start /wait AUTO_CIS.exe >nul 2>&1

:: Tweaks to turn off realtime AV etc...
REGEDIT /S Tweaks.reg >nul 2>&1

:: IF ERRORLEVEL 1 = cis.exe is not running.
:: IF ERRORLEVEL 2 = cis.exe is running.
timeout /t 1 >nul 2>&1
tasklist /FI "IMAGENAME eq cis.exe" | find /I "cis.exe" >nul 2>&1

:: Kill Comodo to stop the scan, clean exit removing tray icon... 
taskkill /im cis.exe >nul 2>&1
:: Force exit in case clean didn't work... 
taskkill /im cis.exe /f >nul 2>&1

:: Delete Desktop icon (Windows Vista/7/8/8.1/10/11)
del /f /q "%SYSTEMDRIVE%\Users\Public\Desktop\COMODO Internet Security Pro.lnk" >nul 2>&1

Install the old “AutoIt 2” v2.64 (I guess v3 could be used, but v2 is a simpler to write the script).

Create the file “AUTO_CIS.aut” and put this code in:

SetTitleMatchMode, 2

; ----------------------------------------------------------------
; Wait for installer window...
WinWait, Internet Security Pro
WinActivate, Internet Security Pro

; Hit enter to install
Send, {ENTER}

; Minimize installer window...
WinWait, Internet Security Pro
WinActivate, Internet Security Pro
WinMinimize, Internet Security Pro

; ----------------------------------------------------------------
; Wait for installer window to pop up again...
WinWaitActive, Internet Security Pro
WinActivate, Internet Security Pro

; Untick "Enable Cloud Based Behavior Analysis of untrusted files"
Send, {TAB}
Send, {TAB}
Send, {TAB}
Send, {TAB}
Send, {TAB}
Send, {TAB}
Send, {SPACE}

; Untick "Send anonymous program usage statistics"
Send, {TAB}
Send, {TAB}
Send, {SPACE}

; Press "FINISH" button
Send, {TAB}
Send, {SPACE}

Put this in “Tweaks.reg” and edit it to suit whatever you want to take out (just comment out keys and entries with a semi-colon) or you can just take the regedit command out of “install.bat” and not bother with a Tweaks.reg file, but I like setting Comodo up like this :slight_smile:


Windows Registry Editor Version 5.00

; TESTED ON: Comodo Internet Security Pro x64 v12.2.4.8032

; Disable Anti-Virus realtime protection

; Disable Auto-Containment

; Disable VirusScope

; Disable Scheduled Full Scan

; Disable Scheduled Quick Scan

; Disable Cloud Lookup

; Do not play sound when an alert is shown

; Stop the intro screen after reboot

; Disable "Website Filtering" in system tray


; Do not show Widget


; Do not show minimize tip window

; Do not show upgrade button in GUI

; Do not show messages from message center

; Do not ask about GeekBuddy

Now right click “AUTO_CIS.aut” and “Compile”.

You should have all of these files in a folder now:


Put the folder in VMware/VirtualBox or whatever and test it works via “install.bat”.

It is automated, but it’s crude. Since Comodo took away the ability to simply run the MSI file to silently install, this is the best way I can think to automate it.

Once it’s tested, wrap it all up in a WinRAR sfx and give it the Comodo icon and there it is, done.

This installer is much bigger (131 MB) than it would be if it was done the old way (40 MB) and there’s extra unpacking this does, but whatever.

Just don’t touch the keyboard or mouse while it’s installing (and that’s why this is crude, AutoIt 2 has to tab around the Comodo installer window and press “FINISH” and so on).

The Tweaks.reg file disables everything, except the firewall. It still has AV scanning on right click files/folders. Also, this removes the desktop icon for a clean look, but you can always comment that out of “install.bat” if you prefer having the desktop icon.

I hope Comodo makes the MSI installer work again so silent installs can be done the old way, it was so much better than doing it this way. This crude method has got the potential to be unreliable and the install might get stuck at some point due to AutoIt 2 missing a key press.

Hi Manc,

Thank you for reporting.
Kindly provide us the exact steps to reproduce the problem so that we will check and report it to the team.
Any related screenshot & attaching video of the issue would be appreciated(NOT Mandatory).


1. Run the offline installer of the latest CIS v12.2.4.8032

2. Go here and run the MSI file:

Even though running the main installer, everything installs fine, the MSI file shows this error straight away:


It shows that in Windows 7, 10 and 11, in a VM and on a real system.

I can use “cis_setup_x64.msi” from older versions ( to make a silent installer and it works fine. The MSI file from those older versions has no such issue.

Hence the problem of not being able to automate the install anymore.

Hi Manc,

Thank you for providing the requested inforamtion.
We will check and report this to the team.


Hi Manc,

We tested and reproduced the issue & reported to the related team.


1 Like