Signing Java WebStart application using Comodo certificate- jnlpcomponent1 error

Hi, I’ve using a Comodo code signing certificate to sign a Java WebStart application. I have used the certificate (.pfx file) to successfully sign my jar.
When I run my application, it first brings up a popup with the jar & its certificate’s details. However, it then shows another popup with an error about the missing Manifest permissions attribute and a corrupt self-signed certificate.

I’ve found that these errors refer to the “jnlpcomponent1.jnlp” file that Netbeans IDE generates when I build my application. This file contains four 3rd-party jars that are already signed using another certificate.

How do I unpack these jar’s (to replace the Manifest with a blank one & delete the .SF and .HSA files) & re-pack it ? Is there a way to manually do it (e.g., at command prompt) ? Can I manually unpack these 4 jars, edit their Manifest, remove the .SF & .HSA files and re-pack them ?
Or do I need to sign them using the Comodo certificate as well ? Please let me know. Thanks.

Note: I have also included details about this as a reply at

Update: I have resolved this problem. Kindly close/ ignore it.

Can you please explain how you solved the problem?