Signed up but no certificate

I signed up for my certificate, but i did not the certificate. I search the support website and I did not find the help for my case. Can you tell me how to get my certificate?




Please submit a ticket at and the support team will assit you.


Thanks a lot! I requested a ticket online!


I signed up for an email cert but after clicking accept it does not go to step 2, hence never completing. This is true in both IE or FF unless I am missing something but can’t find what though ???

Please submit a ticket at and the support team will assit you.

yes !!! they do exactly the same with me it’s incredible , they talk about security but they are just collecting your personnal informations for their newsletter and after it’s FINISH

Im mad, I m gonna burn the place I lost one hour with this society who is not telling the thrue!!!

This is not a trusted company I think it’s not serious we ar’e not just robots !!! !!!
Happy new years punks!!
And try to find a serious company giving me respect and consideration because my time is not for sen se …

We living in a world so crazy now on days, nobody trusty believe me my bro’ n sisters !!!


As many people are having this issue, it is possible that there are issues with the E-mail Certificate system and it will need to be fixed. Comodo is a very serious company and on behalf of Comodo we are sorry that you received nothing after taking your valuable time to receive an e-mail certificate. At this time the best thing you can do is contact the support team using the links above so if there is an issue they can fix it, or if in the slight chance you may not be doing something correctly they can walk you through it so you will receive your e-mail certificate. Thank you for your time.

Kind Regards,


When you sign up for the email certificate we ask for relevant information.

Be assured, we do not take the personal details and then not provide you with what you ordered.

Also, on the application page for the email certificate there is an ‘Opt in’ checkbox, which can be un-ticked so that you do not receive any of our mailings.


I get the same problem about not passing to step 2 but what surprise me is that I tried like three weeks ago and was the same. I like comodo and the spirit of its comunity but I don’t understand why they haven’t advise that this is not working they should close this option or put a sign or something so people won’t start the process and get dissapointed and then complain about it.

my two cents.

I had the same problem but it was my fault… I ignored the fact that somewhere on the route it specifically mentioned that the application process only works with Internet Explorer.

Having started again with IE it worked for me…

Good luck,



The issue is most likely that you have changed the default settings in IE for the ActiveX controls.

Try setting these back to default and applying again.

I went through the application process today, and the pages work.
We haven’t made any changes to these pages in a very long time.

If you still have a problem after reseting the ActiveX controls then please raise a ticket at where the support team are waiting to assist.


Thanks Garry, I’m using Vista and FF but tried with the Ie7 that comes with vista and got the error 438 form the comodo site. Maybe that can help you guys. I ended up using a box with Ie 5 and worked fine. So for peoples reference, just Use Ie 5 if you want to get the certificate at once.


Vista comes without XEnrol which is required to apply for the certificate.

We are testing Vista to find out what changes we need to make to the process.