Shields Up And Comodo Firewall With Defense +

Comodo Firewall with Defense plus gets a message from Shields Up that all tests pass with one exception “Ping Test” All ports are stealth well here’s what it says…

Thanks in advance…

[Quote]Solicited TCP Packets: PASSED — No TCP packets were received from your system as a direct result of our attempts to elicit some response from any of the ports listed below — they are all either fully stealthed or blocked by your ISP. However . . .

Unsolicited Packets: PASSED — No Internet packets of any sort were received from your system as a side-effect of our attempts to elicit some response from any of the ports listed above. Some questionable personal security systems expose their users by attempting to “counter-probe the prober”, thus revealing themselves. But your system remained wisely silent. (Except for the fact that not all of its ports are completely stealthed as shown below.)

Ping Reply: RECEIVED (FAILED) — Your system REPLIED to our Ping (ICMP Echo) requests, making it visible on the Internet. Most personal firewalls can be configured to block, drop, and ignore such ping requests in order to better hide systems from hackers. This is highly recommended since “Ping” is among the oldest and most common methods used to locate systems prior to further exploitation.

Are you sure it is not a matter related to your router?

It very well could be the router, with that kind of information even the slightest chance for a hacker to gain access there must be a way for the firewall to be set up to block it. I’d be interested to see how many other members have that same scenario, here’s the link to Shields Up… ;D


I asked because I had the same problem
and I solved it only by entering the Advanced Menu of my router and setting that (internal) firewall rule to drop ICMP Echo Requests


!ot! Thanks but now something different has happened i uninstalled my Comodo Firewall for other reasons posted in another thread. I’ll look that fix up if i reinstall Comodo products… :-TU


No, if you are sitting behind a router, unless you have a DMZ set up, this test isn’t even touching your software firewall. No amount of configuration of your software firewall is going to change this fact. The configuration must be done on your router.

Cfw 5.8. Firewall set to Safe. Block all incoming/sealth all ports. No router.

Passed, all ports detected stealth


I had this same issue yesterday. I checked the Comodo Firewall several times, but then logged into the router webpage and saw that the router responds to ping requests. I unchecked the box and the ShieldsUP then gave a pass for the TruStealth Analysis.

‘Your system has achieved a perfect “TruStealth” rating. Not a single packet — solicited or otherwise — was received from your system as a result of our security probing tests’

So if you can, check the router’s settings and find out if there is the ability to stop the ping replies.