I’m using Comodo v3.0.13.268 … how can i grant shareaza full access to internet ?

Hi gisot,

I use Shareaza too, when you get a pop up when you first run Shareza, should be a Defense+ pop-up alert asking if you want to Allow Shareaza access rights, choose Treat Application as Trusted Application or Install/updater if the first choice doesn’t present itself and tick the remember me box too next when Shareaza is running it will try to connect to the networks ie’ Gnutella 2 default network. another alert will pop up, I think a firewall Alert asking if you want to allow whatever incoming IP to connect, you can either choose Allow without remember me ticked so that it asks each time you run shareaza if you want to allow an incoming connection or you can choose Allow and remember me ticked and it will have full access to the internet eachtime then.

check out other p2p softwares and see how they set up the rules for comodo firewall.
like emule, edonky, and bit torrent rules

Hey gisot,

try this instead goto this link it says how to setup the Comodo firewall Rule for Shareaza

if you already have a rule for Shareza in Network Security Policy in the firewall tab, then just edit the rule for Shareaza and do that first rule as that link on shareaza’s site says
and if there is a second rule shareaza then edit it too if there isn’t a second rule then create it
and set Action = Block
Protocol = IP
Direction = In/Out or IP I’ve set mine to In/Out both options work for me
Description = you can type Block and Log All Unmatching Requests
Source Address = Any
Destination Address = Any
IP Details = Any
Tick Log as a Firewall Even if this rule is fired if you want the the firewall to log any intrusions in the View Firewall Events Log

a new Allow IP Out from IP Any to IP Any where Protocol is Any rule will automatically be created by the firewall if not straight away then as soon as you perform a search in Shareaza
open up back Network Security Policy and move that new rule above the block rule

With these two rules for Shareza in Firewall/Network Security Policy, Shareaza will only use port 6346 which is the default port for Shareaza in Shareaza settings\Internet\Connection

you can change the port in Shareaza to whatever port you want but its recommended to leave it as it is, your firewall Allow Rule for shareaza will only allow connection to and from Shareaza on that port and block any connection that is trying to connect on a different port ie; any intrusion connections.

The block rule i just tried it another way, because I noticed alot of ppl do not use Shareaza’s default 6346 port. thats why I ended up with alot of intrusion alerts in the firewall log.

so instead for the Block rule you might want to try this

Action = Block
Protocol = TCP or UDP
Direction = In

Description = you can type Block and Log All Unmatching Requests
Source Address = Any
Destination Address = Any
Source Port= Tick Exclude / A Port Range Start Port = whatever you want i chose 1057 end Port = I chose 65535
Destination Port = Tick Exclude / A Single Port = 6346

Tick Log as a Firewall Even if this rule is fired if you want the the firewall to log any intrusions in the View Firewall Events Log

that will silent the intrusion log events and should only Block & log any real intrusions that doesn’t meet your rule allow critieria and Block critieria while still leaving your “shareaza with full internet access”

if you change your block rule to this one ^ then the Firewall will silently learn your settings for Shareaza and create 1 more new rule of its own. so you’ll end up with 3 rules

Disregard this above Block Rule setting ^ it doesn’t quite work right >:(

Thanks everyone for your answers/recommendations … but still when i do the connection test on i always get message that “tcp has timed out and no udp answer has been received from my address” and i get advice that my firewall/router is not configured right. Any thought on this ?

hi gisot,

I was getting something similar and also lowId on ED2k network on shareaza and that test site I was getting TCP unavailable but UDP in green available.

so you have a router too, well I disconnected my router and i passed that test and got high id and could connect to any hub , you could do port forwarding in your router, but trust me that would be such a pain and not actually work well and it would leave alot of ports open. Shareaza hubs use many ports not just 6346, emule and ed2k which u might have noticed are the other networks on shareaza use many ports too, not just port 1412, what i did was i enabled UPNP in my router and enabled UPnp in Winxp Sp2 in WinXP you have to set two services to automatic, SSDP search and discovery and UPnp Universal plug n play, and in shareaza you have to tick that enable upnp in shareaza settings.

when you run shareaza then you will be able to conect to any hub, and in search you’ll notice it will increase in results by 5 folds atleast since you will be able to connect to any hubs and not just hubs that use port 6346.

Upnp is looked down upon big time and is regarded as a major security risk. you have to make the choice to enable it or not. I did and I’m happy with it. since you have CFP 3 whenever upnp services wants to connect like when you load shareaza the firewall will alert you with an allow or block. so if any malware or bad program should try to do the same you can easily not allow it since upnp asks you permission if it can be allowed access to the net or not via CFP 3 just remember though to always choose Allow without remember me ticked for svchost.exe 1900/2869 upnp otherwise you will be giving winxp persmission to automatically connect and use your router, don’t know why it would do that, but well i guess by the same token any malware wouldn’t need to ask if you choose remember me for svchost.exe 1900/2869 upnp. if you choose only allow with not remember me ticked then everytime it needs to connect it will ask permission and you can allow it :wink:

I’ve had Upnp enabled in my router and winxp for 3 - 4 days now and personally I’m happy with it and am aware of the risks invovled such as if i had malware or ■■■■ on my pc, also most say Winxp can control your router with UPnp, i say who cares? it has to ask persmission from CFP 3 eachtime it wants to use the net :wink:

just so you know any upnp app like shareaza when you close it down winxp service 1900/2869 upnp also drops the connection. so in essense upnp ain’t always open like manaul port forwarding.

hope you got a good router though, if its good then it should still stealth your ports even with upnp enabled and shareaza or any other upnp app running