ShaderToy website does not work on Comodo Dragon

As the subject indicates, Comodo Dragon will not display shaders on When navigating to the website CD gives the following error:

The page at says:

Error in JSON: SyntaxError: Unexpected end of input:

I would have posted this in the Bug Reports section but the first pinned message advised to post it here and it would be moved if confirmed. This is a fresh install of CD (never used it before this version). The site works fine using the current version of Chrome (30.0.1599.69). The site also worked with previous versions of Chrome.

yep, you’re right (Dragon portable 29.1, pepperflash 11.8.800.170, win764bit):

[attachment deleted by admin]

This is due to that. Screenshot.
Dragon portable 29.1

Edit: Sorry. But the reference to the Russian.

[attachment deleted by admin]

Hi Enik,

It appears that your graphics hardware and/or software (drivers) are not WebGL-capable, or possibly blacklisted.
Enable this flag: chrome://flags/#ignore-gpu-blacklist and restart Dragon. This might cause stability-issues.

Chrome (but not Chromium) uses SwiftShader in case of old graphics hardware/software.

See also GPU accelerating 2D Canvas and enabling 3D content for older GPUs

Enable this flag: chrome://flags/#ignore-gpu-blacklist and restart Dragon. This might cause stability-issues.
At me changed nothing. Screenshot. Maybe it's on this site. ??? Please,show a screenshot, where it is displayed normally[u] in CD 29.1[/u] ------------------------------------------------------- Edit: All WebGL tests are passed well.

[attachment deleted by admin]

Then it appears that blacklisting was not what caused that the site did not work for you. But it’s worth trying, I think. :wink:

I have Windows 7 in VirtualBox, and accelerated graphics does not work there (tried with Dragon, Opera 18, Chromium 32 (64-bit), Chrome 30). It works fine in Chrome 31 on Ubuntu. :wink:

I also tried with Dragon and Chrome 31 (ignored blacklist) on an old PC with XP, and it did not work in neither of them.

JoWa Thanks.
Thanks for information. :-TU

Sorry, I didn’t realize the forum wouldn’t email me when there were replies to this thread and I never checked back.

I have a GeForce GTX770 using the latest nVidia drivers (331.65 WHQL) on Windows 8.1 (64-bit) so I doubt that my hardware / software are not up to the task. Also, since my original post I did a fresh install of Windows 8.1 and I’m still getting that error.

As a sidenote, the site also works perfectly fine under Chromium.

Have you updated Dragon to 30.0?

You can click on the Notify-button to get notifications. You find Notify above and below a thread. :-La

I’ve tried to update to 30.0 but after CD downloads the update it gives an error “Downloaded file is not properly signed.”

Yes, that has been reported by other users as well.

You can try to run the installer. Download:

I have it installed as Portable. Will it mess up my current installation (ie. change settings) if I re-install it as portable over my current portable installation?

You can copy the folder User Data before you run the installer. Or you can install Dragon in a new folder and copy User Data to the new installation-folder.

Okay, that seems to have worked out okay. Just an FYI that the ShaderToy site is still throwing that same error in CD :slight_smile:

Please open dragon://gpu/ and copy and paste Graphics Feature Status and (if available) Problems Detected here.

Graphics Feature Status Canvas: Hardware accelerated Compositing: Hardware accelerated on all pages and threaded 3D CSS: Hardware accelerated CSS Animation: Accelerated and threaded WebGL: Hardware accelerated WebGL multisampling: Hardware accelerated Flash 3D: Hardware accelerated Flash Stage3D: Hardware accelerated Flash Stage3D Baseline profile: Hardware accelerated Texture Sharing: Hardware accelerated Video Decode: Hardware accelerated Video: Hardware accelerated

There is no section labeled Problems Detected

Also, I found something interesting. I installed CD into a Sandbox (using Sandboxie) without using the portable option and I no longer get that JSON error, but instead I get:

Thanks. All looks good in dragon://gpu/.

I will ask for help. :wink: I think it’s time that someone who actually knows something replies. :slight_smile:


It seems that WebGL is not working in Dragon at the moment. It’s my understanding that Chromium does have support for WebGL so at this point we have to find out what went wrong with the integration and if it can be solved.
I will provide a reply with our findings once the issue is investigated further.

Thank you.