several trusted applications blocked


Today i see in HIPS (safe mode) blocked applications several trusted applications like Viber and Thunderbird email client.

Manually Unblock them doesn’t change anything, after a while they are again blocked. Also they seem to work just fine no matter the “block” i see.

I do not understand why this happens, what it means and how to fix it. I run latest Comodo Firewall only, and Windows 10 pro/64 with 1903 update.


Should go without saying but you need to check the HIPS event logs and not rely on the blocked applications list.

Pixo1 have u checked the logs and seen if the applications are being blocked for access memory.Just asking as I have the same issues on win 10 home 1903 since last night.Not sure what changed unless it has something to do with the cumulative updates that came down yesterday for 1903 but know even steam , uplay and easy anti cheat started being blocked for access memory late yesterday(was no issues yesterday morning with 1903 so this started mid to late day yesterday).

Had hips rules set for all these as well and they worked until yesterday evening, After that pretty much everything got blocked by hips.Only thing that did stop it was turning off monitoring of interprocess memory accesses in the monitoring settings.

Hi Pixo1,

Thank you for reporting, Viber and Thunderbird email client are already in safe list. You have mentioned that several trusted applications are being blocked, what are the other applications that are being blocked. Could you please provide us few samples(files) that has been blocked on your machine and also the screenshot or logs.

Hi, Pixo1.

Could you please collect logs from your device using our cisreportool for these purposes?

  1. Download tool by the link:
  2. Run tool on you device and wait for logs collection.
  3. Logs will be collected and uploaded to our SFTP automatically.
  4. Specify device name on which tool was running in order to be able to find logs on SFTP server for downloading them and further investigation.

Thank you in advance!

Kind Regards,

Guys thanks for the replies.

It seems that Comodo latest is NOT compatible with Windows 10 1903 update. Taking into consideration that Windows 10 1903 by itself created also several problems for me, i restored back to my previous state and i’m fine.

So i can’t provide any information. I wish i could. Sorry about that.

Pixo1 I think your 100% correct.Have been on a few other anti virus websites and few other forums and seems avast and a few others are having issues with hips and Behavior Blockers not working correctly with 1903.

This is sad because it seems that every Windows 10 big update is actually a “new” operating system and breaks a lot of things.

The Blocked Applications screen is a useless function. I would rather see it removed because it causes a lot of confusion.

As futuretech states you need to check the HIPS event logs to see what is happening. That is the only reliable way of assessing. Please provide us with HIPS event logs.

CIS 12 is compatible with 1903. We don’t have enough information about your problem to know what is happening. At first sight it seems confusion caused by the useless Blocked Application function.

You’re too eagerly jumping to conclusion your problem constitutes a compatibility issue.

Please provide us with the HIPS event logs and we’ll start from ther.


I’m not jumping to anything. All i know is that after 1903 update several trusted applications were in there.

As for compatibility issues, i have heard that before many times and it wasn’t the case. As you will probably find out when 1903 will e officially out in masses.

If there are compatibility issues we always want to know but we need to know exactly what is happening. That’s why futuretech and I are asking for HIPS logs. The Blocked Applications function in the main screen is a useless and only creates confusion and I’d rather see Comodo remove it sooner than later.

So I have checked and it seems to be an issue with 32-bit applications that on launch will attempt to access every running process in memory, thus a CIS process which is automatically blocked due to self-protection. Not really an incompatibility but a bug that doesn’t interfere with normal usage of the application.

Hi Pixo1,

Could you please check your personal message and provide us logs for further investigation.