Setup Univeral Media Server to connect?

I did allow all files, but it’s not connected, only when I disable Comodo Firewall, it’s a local server, so it should be connected and can’t know how it’s rejected as I can’t find it’s blocked.

Its bad practice to disable firewall, instead how to allow it?

Using Window 10

Make sure you turn off Windows own firewall, and then add an allow global rule.

Thanks, I did turn off Windows firewall.

Usually this should be on auto discover, but it seems not.

I still not able to figure this out.

When I disable COMODO firewall and enable Windows Firewall, everything seems to be working fine.

I do not see anything in Comodo about blocking the connection or anything, so I know to white list it or even get a notification to enable, it’s really hard to work with it.

Because you need to add the necessary allow rule to the global rules section, by default it will silently block all incoming connections so you won’t see blocked events in the firewall log.