Setting up for allowing Incoming remote desktop sessions

I can’t get my computer to allow remote desktop connections. I just installed Comodo 64 bit Internet Security today. Up to today it worked flawlessly but now it doesn’t work. I have even tried disabling the firewall and I still cant connect. I found a few topics about the subject but what they told me doesn’t seem to work. Please help me. I am a novice when it comes to these things.

Well it seems that I can remote desktop from another one of the work computer in out network. But when I try to come in from the outside it won’t let me. So I know the remote desktop settings are correct in windows.

When I look at the firewall it says 0 blocked intrusions. Shouldn’t it be listing the remote desktop block.

Can anyone please help me with this?

Uninstalling then reinstalling fixed the problem.