Services.exe is blocked every time...

Services.exe is blocked every time and I can only click “allow” or “block”, i.e. I can’t make a rule out of it…It’s driving me crazy as I have to click it at least a dozen times every time a new device or similar is installed.

I noticed that I also have a few other processes, like windows update, that I can’t allow permanently. Again, really annoying. I’ve never had this behavior of COMODO before.

FYI I get this problem in any mode I try, even in installation mode sometimes.

Using Windows 7 x64 and the latest version of COMODO CIS.

Please change your configuration. Rightclick on comodo icon. (Note, This will delete all prexisting rules, you can make back up of your configuration by exporting it)

Switch to CIS to safe mode and try again - did this help?

It is meant that way. You will have to decide on a per case basis and then tick to remember the answer. Services.exe can be called by any program and is capable of making services autostart. Hence the by design cautiousness.

Moved to the appropriate board.

Sorry about that.

The problem is still persisting (yes I think it’s a problem as previous versions never gave me this kind of annoying behavior). I was just installing pdf reader software and I can’t define the app as “trusted”, forcing me to click “allow” every time. The dropdown list only contains “treat as installer or updater”.

Try this.

1.Go to Defense +>Computer Security Policy>delete ‘%windir%\system32\services.exe’
2.Go to Defense+ settings> change it to training mode>install pdf software that you want.
3.change it to clean PC mode.

1.‘pdf reader software’ ?
What exactly did you install and where did you download it?
Acrobat or any other software?

  1. Can you show me the screen shots please?

Are you talking about alerts for services.exe here when trying to install or are you taking about alerts when running the installer? I am confused here…

It’s a general problem, I noticed it first with services.exe when installing a new usb drive. Connecting a new USB device requires me to click allow about 10 times and all other options are blanked out (i.e. I can only click allow or deny).

Second time I got it when I was installing Acrobat reader (latest version 9.2) where I got the same behavior.

The weird thing is that I can go into installation mode by clicking the Comodo icon and changing modes their but it doesn’t have any effect. If I change the defense+ mode to training there is no problem but it’s not very feasible to have to switch to training mode every time I install a new app or device.

I did do something different in regard to previous times I installed Comodo CIS on a new computer. During the installation of the basic apps I ran it constantly in training mode, whereas earlier I was working in clean pc mode" and allowing every app separately. I only switched back to clean pc mode when I was done installing most of my software. Did I F’ up their? 88)


Computer Security Policy>choose ‘%windir%\system32\services.exe’

Click Edit

[attachment deleted by admin]


Not at all.

Please visit COMODO forum everyday!. ;D

COMODO forum is the great place for everybody.