Service is not ready yet when starting CESM Console

I installed ESM on Windows 7 32-bit / SQL2008 Express. It installed ok, but when I attempt to login to the CESM Console is just gives me an error service is not ready yet.

Any suggestions?

At first, did you restart you workstation after installation?
At second, please review information in
Computer Management (Local)\System Tools\Event Viewer\Windows Logs\System and
Computer Management (Local)\System Tools\Event Viewer\Windows Logs\Application

Is there any information about CESM Agent services?

yes, restarted

all logs are ok, 0 errors

Try to turn off UAC.

Release Notes

Software Requirements
CESM Central Service computer

  1. Windows 2003 Server (SP1 or higher), Windows 2008 Server
  2. .NET Framework 2.0
  3. MS SQL Server 2005 Express SP2 or higher

CESM Administrative Console computer

  1. Windows XP (SP2, SP3), Windows 2003 Server (SP1 or higher), Windows 2008 Server, Windows Vista, Windows 7

I have the same problem. I’m running Win 2008 R2 in a VMWare environment.

The Service “Comodo ESM Server” runs for 30 seconds and stops. No error message, nothing in the logs. Console cannot log in when that service is not running.

Called tech support, they were not very good. Basically said that it will not run in a Virtual environment and to try on hardware directly.

Disabling UAC is not the solution.

Update :o

I managed to fix it myself.

I uninstalled the CESM, and reinstalled, however on the reinstall change “localhost” to the actual computer name. This works.

I run ESM Server on Windows 2008 R2 without any problems.
Can you attach system and application logs?

I am having the exact same problem.

Tried putting the server’s ip, it’s name, localhost,, restarting the service… to no avail.

Check if Server starts and check system and application log.

Can you attach system and application logs?

I know it 's been really long since the last post, but since I bumped into the problem myself, I 'm posting the solution (well… what worked for me nevertheless) for anyone who cares…

The message “Service is not ready yet” seems to indicate that while the CESM Service has succesfully started (and therefore no error message in the logs) for some reason it has not initialized properly. The reason (at least in my situation) turned out to be that the SQL Server has not started and therefore the CESM Service could not access the database.

Hence, login to your server, launch the Services management tool and make sure that SQL Server is running… (you might want to restart the CESM Service just for being on the safe side). After that you should be able to connect through the CESM Console.