Service failed to start with exception: CRM.SrvCore.Transport.TdiException


I have installed CESM 1.03 on Windows XP SP2 (both console and server). I have SQL Server 2005 Express SP2 installed locally and I have verified that the CrmData database has been created (in an instance I called CESM)

When I try to login (using Windows Authentication) I get the message

"No connection could be made because the target machine actively refused it.

I’ve tried uninstalling and reinstalling several times.

I think the problem is that the Comodo ESM Server Service fails to start.

I checked in the Event Log and found the following error:

Service failed to start with exception: CRM.SrvCore.Transport.TdiException: When call Listen (0xC0000010)
at CRM.SrvCore.Transport.TransportTdiConnection.Listen() in D:\Work\VS2005\Projects\Comodo\CRM50078\SrvCore\Transport\TransportEndPoint.cs:line 546
at CRM.SrvCore.Transport.TransportRouter.Listen(UInt32 connectionsCount, Int32 port) in D:\Work\VS2005\Projects\Comodo\CRM50078\SrvCore\Transport\TransportRouter.cs:line 108
at CRM.SrvCore.SubSystemCatalog.StartTransport(UInt32 connectionCount, UInt16 port) in D:\Work\VS2005\Projects\Comodo\CRM50078\SrvCore\SybSystemsCatalog.cs:line 199
at CRM.SrvService.CrmService.DoStart() in D:\Work\VS2005\Projects\Comodo\CRM50078\SrvService\CrmService.cs:line 137
at CRM.SrvService.CrmService.TimerElapsed(Object sender, ElapsedEventArgs e) in D:\Work\VS2005\Projects\Comodo\CRM50078\SrvService\CrmService.cs:line 96.

I’ve tried other things like checking TCP/IP is enabled etc. in the SQL Server instance.

What do I need to do to get this working?



Is your OS 32-bit or 64-bit? Such error could happen if 64-bit version of CESM is installed on 32-bit OS or vice-versa.

Nope this is 32-bit XP SP2 and as far as I know I installed 32-bit CESM - I would hope the installer would catch it if I was trying to run 64-bit code on 32 bit OS - would it even run at all if that were the case?

Hi empedia,

Please open up a ticket on and our support team will help you out.

I have notification that build 1.052344.5 might fix the problem. Where can I download this from?