Serious Bug - CFP Locks System

Although CFP has one of the best configuration options + HIPS, it has a serious bug. CFP locks itself, the system (control panel, uninstall of CFP, etc), when the user inadvertently makes any mistake. REAL problem is CFP itself hangs and cant be uninstalled. Moreover, when rebooted (using unplug as the administrator does not have log out privileges also), CPF fails to start along with Windows leaving the system vulnerable to attacks. I wonder why the developers have not checked this. The user guide says “Self Protection against Critical Process Termination”, which is pure non-sense as CPF cannot protect itself from a simple mistake from the user. My contention is if THE USER MAKES MISTAKES/ALLOWS A PROGRAM TO ACCESS EXPLORER.EXE, CPF SHOULD NOT HANG AND SHOULD NOT LOCK ALL PROCESSES. ALSO IT SHOULD START WHEN REBOOTED - OTHERWISE THE BASIC PURPOSE OF HAVING FIREWALL IS DEFEATED. I tried the same thing with Online Armor and it does not lock nor does it hang when the user makes mistakes/allows a program to access acCess Explorer.exe inadvertently.

Coming to what actually happened.

Three days back I installed CFP (version on my XP. I was amazed by its configuration options and HIPS. Everything worked fine on day one. I wanted to test it more and on day 2, i downloaded “aquaworld” an animated wallppaper from Softpedia. Real problem started when I actually started to install aquaworld. During installation, I went on clicking “Allow” in CFP popups including to the one which said the program wants to access “explorer.exe”. Once I did this, CFP hung and I could not open the CFP window. I also cannot access control panel, the uninstall option of CFP, and the funny thing is I cannot log out of my own systme-Its really a pity that such a wonderful firewall can do this. So, I unplugged the system and rebooted XP. Once I logged in again, there was no CFP in system tray, I could not open control panel, I cannot uninstall CFP from its uninstall option, and again I cannot log out of my system. Finally, I have to log into Safe Mode in XP to uninstall CFP. Note again: I performed the same things in ONline Armor and it did not hang/did not lock my whole system properties.


No reason for caps and its not a bug if you simply followed instructions. Read here. I have Comodo running on 5 XP machines and does not hang. Every think its your pc and not Comodo. When your installing something use install mode. Works just fine.

Vettetech, i know that training mode and installation mode would not have caused the hang problem. But I cannot apply training mode and/or installation mode for the applications I do not trust. By the way, the “aquaworld” application, though downloaded from Softpedia contained win32/matcash. So, how can I apply installation mode for any unknown application.

What I have stressed in my post is that CFP should not hang whenever a new application (may/may not contain virus) is installed in clean PC mode/Safe Mode and that the user inadvertently allows the application to access important processes (in this case, explorer.exe).

Comodo is not hanging its learning. There is a pause from when a program is launched for the first time till you get it. Online Armor acts the same way. Hangs once when you start an application it hasn’t learned yet. After that it does not hang.

When you launch a program that Comodo has not learned yet there is a pause. This is cause Comodo is checking to see if its safe then asking you if you want to allow the program to start. This is perfectly normal and happens once.

CFP was not learning, it hung forever. I wasnt able to open the control panel (to unistall CFP) and even worse I was unable to log out of my own system. I had to unplug the system to system to restart, and when I restarted XP, CFP wasnt there (It did not load). I tried the same thing with OA, It doesnot hang/crash-atleast when user inadvertently makes/allows applications access to key processes.

Vettetech, u can also look at another post “lockst user out”, which is also on the same locking out problem that I encountered

Please look at “Comodo Firewall v3 locks user out” post

If you locked yourself out then thats cause you click block on something you should have clicked allow on. Comodo just cant lock you out unless you allow it to. You need to read all your alerts and apply the appropriate rule. If your system is perfectly clean then there is no reason to block anything.

Ive been using Comodo for around 7 months now and never locked myself out. All of my family uses it also and never locked themselves out. My Mother knows nothing about computers and still has never locked herself out. So I guess when you lock your keys in your car its the car manufactures fault and not your own. Sorry modders.

No, I clicked “allow” for the installing application which tried to access explorer.exe, after which everything happened. Please look at “Comodo Firewall v3 locks user out” post, which also throws light on teh locking out aspect of CFP. It happened to many not just me. I am just testing the many beta versions of CFP. CFP so hurriedly releases numerous versions one after the other that they contain numerous bugs.

Ok well I am done. But just one my thing to add. Comodo cannot lock you out on its own. It needs user input to be told what to do.

Ok, Vettetech, Thanks, even I am done with it. But please have a look at “Comodo Firewall v3 locks user out” post in Bug Reports. THe problem is similar to what I have. Let me know ur comments after going through that post.