Selecting "Enable Anti-ARP spoofing" Blocks Entire Internet [M1219]

1. The full product and its version:
COMODO Internet Security 8.0.332922.4281 BETA

2. Your Operating System (32 or 64 bit) and ServicePack revision. and if using a virtual machine, which one:
Windows 7 Home Premium x64 SP1 - Real Machine

3. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?:
The change to the configuration which causes this is “Enable Anti-ARP spoofing”. Other than that the configuration is default.

4. Did you install over a previous version without uninstalling first, or import a previous configuration file?:
It is a clean install

5. Other Security, Sandboxing or Utility Software Installed:
No, only CIS.

6. Step by step description to reproduce the issue. Or if you cannot reproduce it, what you actually did before it happened, step by step:
1: I installed CIS v8 Beta and rebooted
2: After reboot I select the option for “Enable Anti-ARP spoofing”.
2: After this I find that I have no internet connection available.
3: Unchecking “Enable Anti-ARP spoofing” allows my computer to communicate with the internet.
4: A video showing this issue is attached to this post.

7. What actually happened when you carried out these steps:
If “Enable Anti-ARP spoofing” is selected my internet connection is blocked.

8. What you expected to see or happen when you carried out these steps, and why (if not obvious):
Selecting “Enable Anti-ARP spoofing” should not block my internet connection.

[attachment deleted by admin]

Please try reinstalling CIS by following the advice I give in this topic. Be sure to run the removal tools from Safe Mode. Also, while still in Safe Mode, make sure that the Comodo internet driver has been removed before booting back into Windows and trying to reinstall.

Please let me know if this is able to get it working correctly.

Thanks.

Chiron it is already a CLEAN install. And as I said in this bug. Default settings has no problem. With my configuration ,that I attached, has this problem. I hope I can expain.

I apologize for misunderstanding. I misread your post the first time.

If possible, could you revert to a default configuration, then figure out which of the changes you made caused this issue? My concern is that if this issue is specific to something else on your computer, the devs may not be able to ascertain what is causing the problem from the attached files. However, if you can figure out which setting caused it I’m nearly certain they can identify, and fix, the issue.

Thanks.

Ok I will test all advanced firewall options to figure out which one blocked the whole net. Then you can please change the first post if you understand me. (sorry for bad english)

Let’s worry about editing the first post only after figuring out which firewall options cause this problem. Let me know what you find, or if you have any questions.

Thanks.

I found out what cause this problem. I seleceted “Enable Anti-ARP spoofing” into advanced setting of Firewall. It blocks my whole ınternet.
I tested and I am sure on it! You can see the problematic config : http://prntscr.com/4o4igc
Please Chiron change the first post and titles.

Thank you. I have now edited the first post, and altered the title. Does everything look correct?

Also, would you mind attaching a process list? I have selected that option and have not experienced problems. Thus, perhaps this is somehow related to a process running on your computer. I’m not sure, but I’d rather send that information with the report, just in case.

Thanks.

Did you test this issue on 4142? It might be a problem related to your router’s settings.

Thanks.

Chiron, looks good with corrections. I added the new configuration and Killswitch report into first post.
Thanks again

I have a little laptop to test new v8. I have no multiple PC to test the issue. When I use last time CIS 7 it has no problem like this. I can assure you.

I was hoping that you might use a virtual machine. That would help a lot (to replicate the issue).

Thanks.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Hi Chiron,

I created a video that shows this bug. Can you please add this video to first post ?

I attached here.

[attachment deleted by admin]

Done. Thanks. :smiley:

Hi Chiron! Please send firewall logs and network settings. Please check presence of two identical MAC addresses on the network.

I believe you are a Comodo staff member. If that is true did you mean to ask yigido for this information?

Yes. I will try to understand this problem.

Hello,

This problem still persist in the new beta. (8.0.0.4314)
What should I do ?

I have updated the tracker, and mentioned that if they still need more information they can contact you directly. I hope that’s okay.

Thanks.