seems to block Firefox (or at least VERY slow)

Hi, I have been using Comodo Firewall Free for many years with no trouble or issues. I use Custom Ruleset on the many times I installed it. Previously when I start Firefox, it asks me if I want to allow it. I always (Remember Answer) Yes, Treat As Web Browser.

With my latest new motherboard and fresh Windows 10 Pro install, Firefox will not find any websites with that setting. (Microsoft Edge does work with the Web Browser rule). If I change the rule to Treat As Trusted Application, the sites come up and Firefox works.

I am not an expert, but I assume Comodo has the Web Browser settings for a reason and I want the intended protection, but I don’t know why on this new install “Web Browser” is blocking Firefox, but works with “trusted Application”. My other desktop computer and my laptop work with the “Web Browser” rule.

Any ideas? THANKS!

Try checking the log to see what is being blocked.

I persisted and found the problem. Under Firewall settings, Advanced, I checked protection on all options just like on the desktop computer right next to this one with virtually the same setup. For some reason the option “Enable anti-ARP spoofing” blocked the internet from my browsers (even Edge which I mistakenly thought was unaffected). Unchecking it allowed internet access. My second computer has it checked and it works OK.

I’m not sure what the setting does, but I can live with it since it wasn’t checked by default.

Thanks for reading.