"Security Level" can't be changed

I’ve been using Comodo for 6 months and love it. I recently installed it on a second computer in my house (Windows 2003). If I use Microsoft’s Remote Desktop to connect to the computer, I can’t change the “Security Level” from ALLOW ALL to CUSTOM. Is there some sort of undocumented restriction at work here? If I’m logged in as the administrator, I see no reason why I shouldn’t be able to change this setting remotely.

G. Eggold

I’ve been having same issue: seems it’s a feature… not allowing over-the-network-security-configuration. Tbh doesn’t really bother me… what is is if I try to use Outlook on the remote PC with Comodo on then Outlook fails to connect to my ISP 95% of the time… or at least I’m fairly certain I’ve seen it work sometimes. Maybe I’m wrong and it’s only ever worked when I “Allow All”… Anyone able to advise how to set up Comodo so Outlook will work in an RDP session?

Thx in advance…

Ok… seems like the solution was easy… just add Outlook to the list of safe applications and now it works in both local and in a remote rdp session. Sweet.

Btw reason I want this configuration is I’m using an Asus R2H with 7" screen which is enough when portability is needed, but it’s great to be able to remote in instead from a proper screen/keyboard/mouse whenever possible. (S) Norton (which comes prepackaged) and eTrust both totally killed the paltry Celeron processor in the R2H, but Comodo works a treat. (J)

Nice job guys… but please don’t bloat this like the commercial guys have done theirs. And please don’t assume I need to be wrapped up in cotton wool, give me options I can switch on/off as needed, not dictats for the idiot masses!

k.i.s.s (:LOV)

Hey geggold

I’m not 100% sure here, just an educated guess.

In WinXP/2003 changes that affect the registry (I’m guessing security in CFP does) is restricted to local Administrators. It is possible to change this behaviour, just Google Remote registry administration windows 2003.


The problem is back and more insideous. I logged in the AM and found that Comodo was essentially disabled. The Security Level is set to CUSTOM, but all 4 Security Monitoring areas (Component, Application, Network, and Behavior) are turned OFF and I cannot turn them back on. Nothing has been changed on the system in the last week and it was running just great a few days ago. Anybody else seen this?

The bad news is that my system is now WIDE OPEN. This is not good!

It would be nice if the vast registry settings that control Comodo contained an obvious key that indicated Comodo’s protection level. For example, I could tell Comodo to NOT protect my registry settings; I should then be able to easily re-enable the NETWORK MONITOR by changing the registry value and restarting (or at least confirm that this monitor is disabled).

That’s not it. I have ADMIN rights on my machine. Plus - the settings can’t be changed, even when I log in as the administrator.

Sounds similar to problems experience by some in a multi-user login/switching environment. Might look here: https://forums.comodo.com/index.php/topic,7036.0.html. If you have multiple users, some people have had some issues moving between user accounts.

If that’s not the case, then I would say there’s a faulty install (possibly active security software interfered).


OK. Here’s the deal. This problem certainly appears to be a “multi-user” problem with Comodo as described in the post before this one.

In Win03, administrative users can use Remote Desktop to connect to my machine. When they do, Comodo goes mental. I DID see two instances of CPF.EXE running, one under my id and one under the adminstrator id.

I was able to logon under the admin id and KILL one instance of CPF. I then logged out and confirmed that the only instance of CPF.EXE was mine but I still didn’t have control of Comodo.

I shut down Comodo using the GUI and restarted it. No difference - still no control.

I logged out and logged back in. No dice - still no control.

I rebooted my workstation. Finally! Comodo was back and running.

I next used What’s Running software to change the Startup parameters of Comodo so that it only starts when I logon. The next few days will tell if this strategy keeps Comodo running.

I pray this problem gets fixed in the next release since the flaw results in a non-functional firewall which leaves the system wide open.

Do let us know how that works.

Also, if you would, file a ticket with Support http://support.comodo.com/ about the issue. Include a link to this thread for reference. I want to make sure they have as much information as possible about this, so that a fix can be accomplished.

If they give you a response indicating that they have it under control, please let us know. In general, keep us informed…



I have opened a ticket and I will certainly use this thread to keep everyone informed. Thanks.