Secure Shopping blocking Hyper-V [M2148]


I am using Visual Studio 2015 with Xamarin in order to create Android apps.

Before I upgrade to the latest Comodo Internet security (V10.0.0.6092) I was able to run with the previous version of CIS the Android emulator via Hyper-V without problem

However now that I upgrade to the latest CIS I cannot run the emulator any more.

Now I get error: Could not launch ‘VS Emulator 5.7" Marshmallow (6.0.0) XHDPI Phone’ device. Exit code 10.
I find out that is caused by the Hyper-V not being able to start.

Then I unistalled the CIS and the emulator worked.

I installed CIS again and Hyper V stopped working again.

I tried disabling the HIPS but Hyper-V was still not working.

I disable all the features of the CIS (Antivirous,Firewall,HIPS,…) but Hyper-V was still not working.

I terminate from the task manager the all CIS tasks but the Hyper-V was still not working.

See attachment for error.

I have:
Windows 10 64 bit,
Version of Microsoft XDE 10.0.10586.0

Any suggestions on how to precede?

Hi bozziev,
Welcome to the forums.

Could you kindly try importing Internet Security configuration?

example steps :

  1. Advanced Settings
  2. General Settings > Configuration
  3. Import > Select : C:\Program Files\COMODO\COMODO Internet Security\COMODO - Internet Security.cfgx
  4. Activate (imported) configuration
  5. Restart system
  6. Recheck issue

Thank you.

Dear Qmarius thank you for our help.

I did what you asked but the problem still pressists.

Do you any other suggestion?

Since with the previous version of CIS I did not have this problem, I suspect that it should be soemthing from the new features that it is causing the issue.

I have attached the message that I got after trying what you told me.

Thank you.

Just to double-check (again), are you using default configuration?

Please provide coreinfo log.
Get CoreInfo: Coreinfo - Sysinternals | Microsoft Learn

Make a batch file with following content :
pushd “%~dp0”
coreinfo.exe -v > log.txt

Run batch file with administrator rights.

It would be great to know your exact steps & links to apps. :slight_smile:

Thank you.

Yes. I am running the default configuration.
Also I have re-install CIS couple of times and all the times the result is the same.
When I remove CIS Visual studio 2015 Android emulator using Hyper-V is running, and after I install CIS it stops working.

I have upload the log file.

The steps I am doing are:

  1. Install Visual studio with Xamarin following the installation steps.(Windows Installation - Xamarin | Microsoft Learn)
    I choose the option which uses the Visual studio community installer and not the Xamarin unified installer.

  2. After the installation is complete, I update the Android SDKs .

  3. I make a simple android project in Visual studio and when I try to deploy it to the Emulator, the emulator does not start and it gives the error code
    “Could not launch 'VS Emulator 5” KitKat (4.4) XXHDPI Phone’ device. Exit code 10."

Just for the record CIS had similar problem before:

Thanks. Can you also run it with Hyper-V disabled? Looks strange.

I’ll forward the issue.

I know. It could be a regression. Not very sure.

Thanks. Reported issue. It could take some time until it’s processed.

Thanks again.

I wonder if its caused by secure shopping and/or internet security essentials? Do you have either installed? Another user had issues with hyper-v not working but then worked again when they only had installed comodo firewall and they could turn on enhanced protection mode under HIPS settings without hyper-v breaking.


Based of futuretech suggestion I solved the problem.

1.I uninstall CIS.
2. Restart PC
3. I run the Hyper-V emulator and leave it running.
4. I installed the CIS without the Secure Shopping (I still had Hyper-V running during CIS installation).

Now Hyper V and the CIS suite without the secure shopping are working fine.

So probably Secure Shopping was preventing the Hyper-V from starting OR the fact that I installed CIS with Hyper-V emulator was running.

Despite that not having the secure shopping solved my immediate problem I still would like to see Hyper-V and Secure Shopping working together because I think it is a very good addition to CIS.

Please do not close the case until you figure what was going on with Secure Shopping.

Thank you for your assistance and looking forward for CIS update.

That’s very helpful, actually. Thanks.

I can confirm that the problem is Comodo Secure Shopping.

I tried to disable all features of Comodo Firewall and also to uninstall it, but only after the uninstallation of Comodo Secure Shopping Hyper-V started to work again.

I think Comodo Secure Shopping drivers causes some conflict with vmwp.exe executable, because in Windows Event Log I found several app crash report for that process.

Yeah I thought it was secure shopping based on reports thanks for confirming and I have updated the tracker indicating it is a Secure Shopping issue. Though I wonder if it is by design that SS help protect against hypervisor based rootkits? thus blocking hyper-v.

Moving to resolved as this should be fixed with Comodo Internet Security v10.0.1.6209. If you still experience this issue please make a reply or PM a board moderator thanks.