Secunia PSI showing different versions [merged]

Last night and again tonight, On my laptop, PSI shows my Comodo CIS as, while Comodo shows it as I checked the cis.exe file and sure enough PSI is correct. Even after several restarts. Then I reinstalled CIS, but the executable remains the same. What might be going on?

I edited the topic title to be more informative and to show it is a merged topic. Eric

I checked the CIS instalaltion folder. All files version number ending at 4674 except but msica.dll and cmdinstall. The latter two both end at 4792.

Also the driver files as stored in system32 and system 32\drivers have version numbers lower than 4792.

When looking at the release history of the v 8.2 branch it shows there have been several small updates that appear to have required adaptations to some of the CIS binaries rather than most of them.

How does CIS get shown in Programs and Features? With me it shows up as 4792.

When running Diagnostics does not show an error than your installation is intact. I don’t know why PSI shows a different version number because I don’t know how they check version number.

As I wrote, the main executable, cis.exe, is 4674. I would think that’s a reliable way of determining the version number. At least, that’s what PSI thinks fwiw.

Fwiw. I think the most reliable way would be the version number by the installer as is stored in the registry and shows up in Programs and Features because the version numbers of the various binaries may differ with point releases.

All I can advice is to report this to Secunia. I could not imagine that this only happens to CIS.

The version number showing in Programs and Features is 4674.

That’s different than my situation. Can you check the version number of msica.dll and cmdinstall in the CIS installation folder? I am on Windows 8.1 x64. What Windows version are you using? What does CIS report when you run Diagnostics?

They both show 4792. Win 8.1 x64 Pro. There is a problem with Windows update right now, in that it’s freezing on the last week’s batch of updates. I’ve got a thread on MS Answers working through it - Redirecting

What do I need to run diagnositcs? Thanks,

When both files show as 4792 then there is no need to run diagnostics. Although you might want to try run Diagnostics to see if it fixes the version number in Programs and Features.

You could try the Windows Update Troubleshooter to fix the problem with Windows Updates: Windows Update: FAQ - Microsoft Support .

Thanks, but that Windows fixed some thing but not updates.

What or where is Comodo diagnostics?

Diagnostics can be found here.

Thanks. No errors.

If CIS still shows 4674 in Programs and Features then that’s minor bug. Is this a clean or upgrade installation?

In case of doubt check what version number CIS or other programs report when PSI shows a different version number.

It started as an update, repeated a few times.

I’ve been writing about my desktop Win 8.1 PC, but my laptop, Win 7 x64 Home Premium, has the same issue. I hadn’t used the laptop for awhile and did some extensive updates Thursday, which had the same general PSI problem with two or three other programs; i.e., they were up to date but PSI didn’t think so after restarts and rescans. Those others resolved themselves one way or another over the last couple of days. I tried a resintall of CIS on top (laptop), but that didn’t fix it (but did bring in all that other stuff I had to uninstall, in spite of unchecking everything).

Comodo updated the CIS installer at February 12. Did you use that installer or did you use the previous one? The reason I am asking is that unchecking things in the installer did not get work. I don’t remember seeing that with the previous installer.

Must have been the previous installer, which I found on Comodo with a google search (laptop). Going directly to the main website on my desktop PC, I found it. Chromodo and GeekBuddy aside, it didn’t make a difference on the laptop.

No, in fact it was the current installer, cispremium_installer_6100_08.exe, installs Chromodo and GeekBuddy even if the boxes are unchecked. For unrelated reasons, I uninstalled CIS today and then tried a reinstall. When I went into custom install and unchecked them, it returned returned errors and killed the install each time (Error 2 and/or 1603/GeekBuddy). Then I did a system restore, but that didn’t work with Comodo.

Finally, for unrelated reasons I did an in-place repair install of Win 8.1 Pro x64. Comodo now runs, but won’t update, returning errors at Signature, Website Database, Recognizer and Program updates. After closing it down, I tried copying over all 404 files in the Programs folder the backup, and 402 copied, but that didn’t fix it. The files that didn’t copy are cmdstat.dll and dbghelp.dll. Diagnostics, however, doesn’t show anything to fix.

Copying files from a back up folder has me a bit weary and worried. I would suggest to reinstall CIS. First uninstall regularly and reboot to Windows Safe Mode. Then run this Clean up tool as admin. When done boot back to Windows and run Windows Installer Cleanup Utility. When it show traces of CIS and Geekbuddy let it remove them. Then try installing CIS again.

Let us know how things go.

Sounds like a plan until…every install is going install Chromodo and GeekBuddy because that’s what the latest Premium installer is doing.

Big problem. Comodo didn’t show as installed. So I went into Safe Mode and ran that utility you suggested. It didn’t find much of anything. Then I came out of Safe Mode and restarted normal mode, but now I can’t get an internet connection on the computer, only through the router; i.e., presumably somethng happened running that utility which wiped out my network connection! The cable feed is fine, but no IP4 connectivity.

Update: Ok, I just did a system restore and got the internet back. Then I ran the utility again and was able to get out of safe mode without damage this time. Got rid of Comodo remnants, did a couple of reboots and after some errors, finally got CIS installed. Now, is there a way to copy back the previous excluded paths and application rules, or does it have to done manually again?

Update 2: Have to laugh: CIS is back to where this thread started, showing 4674 while PSI shows 4792 as current. CIS says up to date and diagnostic = no problems.

Glad you’re back on track. When I was writing my instructions I wondered if I should add what to do in case the network connections gets blocked after installing or using the clean up tool. With hindsight I should have. What happens then is that the Inspect package filter driver didn’t get uninstalled. That can be done manually in the Properties of the network adapter. Sorry about that. It gave a lot of extra work.

Don’t you mean CIS shows 4792 and PSI showing 4674? :wink: