Secunia PSI does not work?

Hi to all,
I’ve been experiencing problems with Secunia PSI since I installed Comodo Internet Security–more specifically, the free firewall and Defense+. It seems that, somehow, the PSI app gets stucked in a c:\Users\Default\Appdata\Local loop (according to Sysinternals Process Explorer).

Do you know if there’s any issue here related to COMODO?

Thanks in advance!

P/S: The only time I’ve seen this loop was when I was trying to install Visual Basic 6 on my laptop.

WinVista Home Basic SP2, Secunia PSI 1.5, COMODO Firewall 3.1 and avast! Home 4.8

There are many Comodo/PSI users here. I’ve never had any trouble, and don’t think I’ve seen reports of any. Have you by chance inadvertently blocked PSI? There is a Secunia entry in the trusted vendors list, but I don’t know if that covers PSI.

Try deleting any Secunia entries from your security policies, then put D+ in training mode and try starting PSI. Switch back to your previous mode after trying to start PSI.

PSI still does not want to work. Normally scans take about 10-15 min (top/minimized), but today I’ve kept it for 21 minutes and it’s stuck in step 3.
BTW, I uninstalled it, rebooted twice and then reinstalled, but still no chance, neither with Defense+ set to “Training mode” nor “Disabled” nor “Inactive” (deactivated Defense+ via the GUI, rebooted).

Any ideas?

EDIT: Uninstalled temporarily COMODO, and… PSI works again! (?)
EDIT2: I reinstalled COMODO and PSI stopped working AGAIN… Only the firewall active, I selected the first option at the Configuration Wizard.

HeffeD, could you please check your configuration for PSI and tell me the values? I don’t have a single idea about how to fix this without uninstalling CIS…

EDIT: I’ve narrowed this down- somehow CIS blocks the starting of psi_mf.sys (PSI minifilter driver). This seems to lead to this loop. Any ideas?

I have it set as a trusted application.

And all the other configurations? I mean, the Monitor Settings sections of Defense+ configuration window…

I run in the internet security configuration with D+ in safe mode.

And these are my settings.

[attachment deleted by admin]

I’ve changed my settings accordingly. Let us see if this works…

Nope, everything is set to the config shown in the screenshots, and PSI has “Trusted Application” permissions.

Take a look at my config in the screenshots.

Anything else I can do to make Secunia work as expected? :frowning:

If not, I’m sorry to say that I’ll have to uninstall permanently Comodo and return to ZA (and I don’t want to… :-[)

[attachment deleted by admin]

Have you tried putting psi_mf.sys in your D+ safe files list?

You could also try removing the security profile for PSI again and put D+ in training mode and restart your system. If D+ was blocking something crucial at startup, this should learn the process instead of blocking.

If that doesn’t work, I don’t know what the problem could be.

I’ve now rebooted applying the configuration you’ve told me. It seems that PSI still doesn’t want to work.
Nevertheless, I’ll let it run for some time, maybe it takes longer than usual due to the new program (i.e. Comodo).

Oh God, in the middle of the scan my programs listing got corrupted. I’ve uninstalled Comodo -again, but saving the preferences before :slight_smile: - and now I’ve done a new scan. Fully completed.

I’ll reinstall Comodo with PSI enabled to start at boot-up and with authorization to monitor programs. If this doesn’t tell me what is going on here…

P/S: I’ve already submitted a ticket to Secunia in order to find out if this is some sort of incompatibility or just TOO LONG time to scan. Btw, the last question: which time does it take for your PSI to complete a full scan?

Thanks in advance, HefferD! :P0l

3 minutes, 2 seconds for a full scan.

Good luck! I hope it works this time. :slight_smile:

Aw ■■■■! PSI is crazy!
According to Process Monitor, it starts parsing the Program Files and Appdata directories, and when it finishes scanning them… it just says: “Thread Exit” “Thread Create” and after a while, it parses everything again but backwards. (loop).

Oops, if I try to close Process Monitor, I’ve got a hang guaranteed. (Pretty strange: a hang where I can’t click anything BUT the cursor moves?)

Btw, the minifilter does work with CIS installed. So, where is my problem?

  • Psi.exe stated as Trusted Application
  • Psi_mf.sys too
  • Secunia ApS and Secunia as Trusted Vendors
  • And while I’m doing the scan, I tried installing and uninstalling some programs, and… it recognises the action!!

Last thing: Secunia replied to my ticket and they said the same as you, they never had any issue with CIS.

Maybe there’s some sort of incompatibility between CIS and avast! 4 Home that breaks PSI? That’s the last thing I can think of. If this is not the problem, I’m done! :cry:

EDIT: Yes, I’m done. I’ve deactivated kernel-mode Comodo drivers (ie cmdguard.sys), reactivated them, uninstalled avast!, reinstalled avast!, unistalled Comodo, reinstalled with firewall only and PSI keeps behaving the same way. Sorry to say, but I’ll uninstall Comodo.
I’m really disappointed by this. I know Comodo is one (if not the) of the best firewalls available, but I can’t keep it in my computer if it breaks the functionality of a program like PSI.