Secondery program problem ?

Hiya there

I’ve noticed that in older versions of CF it showed alerts when a program tried to access the internet via piggy backing a ride on IE.

Lets say i install application A and then decide that i do not wish to let application A acess the internet by blocking it in CF.

Now when i start IE which of course i DO want to acess the internet, sometimes another application tries to piggy back a ride with IE to get to the internet, now CF pops up an alert telling me that application A is attempting to acess the net via IE (which is great) but if i do not allow application A it also stops IE from accessing the internet too, now i never had this problem before with any firewall once a program was blocked it would stop it piggy backing a ride in IE without also blocking IE if you see what i mean.

For this reason i have returned to ZA and am wondering if the new version (released this month) has solved that problem.

Many thanks


It’s a known issue. When COMODO thinks that IE is being attacked, it blocks Internet access. Restarting IE restores that, because the browser will start a new session and the ‘attacker’ will be out of its memory space.

Paul Wynant
Moscow, Russia

I too, have the same problem, constantly with 2 or 3 apps I wish NOT to allow to communicate out. Since you say it is a known problem, I must ask these 2 questions:

  1. will it be resolved? if not, please say.
  2. if it is resolved, are there some rules you can write here that make the problem go away?

thank you VERY much in advance. This is a real ■■■■■■ of a problem.

Hi, massimo1!

  1. I’m not a COMODO official, so I can’t make any promises here. The only thing I know is that the next version will solve the problem from what I understand.
  2. I hope this can be of some comfort: it’s been two weeks now that I last saw this type of messages. If you block, you HAVE to restart your browser. I you allow you will have the best chance of the message not appearing again…


Paul Wynant
Moscow, Russia

thanks, I will wait for the next version. Actually re-starting the browser was not effective. I had to go into comodo and delete the offending application trying to piggy back on the browser, then re-start the browser. But that doesn’t always work. Sometimes an application is very insistent. Also, if I did manage to succeed, when I used the offending app again by itself, it lurked out there again til I fired up the browser and then the whole problem resurfaced.