search problem with DC

I configured Comodo Firewall (latest version and updated) as advised in FAQ for DC connections. And all is good …but no search function (:SAD). When I start a search nothing is happening. But if I set Comodo to ‘allow all’ the search function is back. I am connected to the hubs and I can get lists.
So where is wrong?

My settings:
direction = in
source IP = any
destination IP = my IP
source port = any
destination port = DC port for TCP

direction = in
source IP = any
destination IP = my IP
source port = any
destination port = DC port for UDP

Any help?


Any reasons this is not being answered? The only question i have is, what number is that in the lst of rules (as they are compared with the proposed communication in order from Rule 0, rule 1, 2,3,4, etc.

cheers, rotty

Those rules are no. 7 and 8. The no.9 is that one with block all. I already moved my rules before the default one with "TCP/UDP out’.

Well i actually don’t have the COMODO firewall or DC in front of me, so maybe their is someone else experianced with both?

cheers, rotty

Please show us your current Rules(screen-shot)


I believe you need tcp set for both in/out and udp set for both in/out.
You only have in set.
I would suggest either trying that and see if it works or just remove the rules for dc and set up dc as a trusted application.

Hope this helps.

Dr Pete

Voila rki screenshot with my rules. As it can be seen there is a rule (made by default at firewall installation) for TCP/UDP out where all are set to ‘any’. So I don’t understand why should I make another one.
I will try the suggestion with trusted application but I don’t think it will be the same security.
And after all it is an issue of understanding what is happening, not only for solve the problem. As I said already if is necessary I make Comodo setup temporary to ‘allow all’ and all will be OK. But I like to learn about something especially if the software is interesting (and Comodo sure it is for me).

[attachment deleted by admin]

Hi Richelieu,
I should have been clearer, under application monitor is where you set up this rule.

Hope this helps you get searching. I have it set this way and works, if you do set application trusted I would just do that for testing. Its a quick fix to get you working then set up rules to block and allow what you want using dc.

Dr Pete

DrPete: I put StrongDC as trusted application and still no search. I have no ideas about this issue.

Now I have another problem: in my workgroup doesn’t appear my computer network name. I see all others computers and acces them but my name isn’t there. If you look at my screenshot above you will see I defined my network as trusted zone. Explanations?

Lets do a few things that will narrow this down.

  1. Under dc settings switch to passive mode.
    Do you use a router and are the ports forwarded? I assume you’ve already done these and have used dc before to search ok.

After you do a search using dc look in the activity log under comodo f/w and see if anything is getting blocked and logged.
You should also see dc in active connections.

As for why you now don’t see your workgroup under network name, not sure about that just yet.

I assume you have a network setup with a router here, without the ports forwarded for dc and your static ip set this application is going to change everytime depending on which computer gets turned on first. You should also set a static ip for your computer under the router settings. So everytime you turn on your computer you would be

Hope this is helpful,
Going from memory here so help me out and report back clear on what you’ve done and results.

Dr Pete

In destination IP you should have your “zone”.

Did you by chance disabled some of your default services?
…I’m not sure which one tho’. But I’m quite sure it’s caused by a disabled service.

Try enabling “terminal services”.
If that doesn’t work, you have to try one at a time… like “server”, “computer browser”, “routing and remote…” or any service that have something to do with LAN and/or giving names in that enviroment. How many of the default have you turned off?

have the same problem…

but after all configurations an logs check i found the issue altough i cannot find a way out

comodo determines search results as udp flood attack and blocks it

any solution?

If you go to security/advanced/advanced attack detection and prevention, you can set the values for flooding. That’s not too secure i think, because if you encouter a reel attack, CPF will let it through… You can try it as a temporary solution though…

… yep but it would mean to increase flood values to over 500 … and in big hubs to even more…

still prefer to disable during search and then reenable…

perapplication rules will solve this ?

In application monitor, have you tried to set it to allow all activites and allow invisible… and skip advanced…? If you have not, then try it and see if it works.
Do you have a network monitor rule for DC?

i have an unique rule for opening incoming ports on all ip (tcp/udp) (4 single ports for emule and dc, works well for kad net in emule )

now i’ll try what you said


no way, nothing changed i only noticed thet it shuold be not only that udp flood but also the other security alerts (when search results aren’t much)

ps my provider works under a NAT is much like a giant lan … this should be the reason i don’t recognize any of the log ips as mine but dc++ in my case is supposed to be set to connect only to hubs inside this “huge lan”

I’m do have the same connection as you have. A huge lan…
I’m behind a router, thats why i have a “zone”.
I’ve not tried DC for a while, but my torrent program works.
I have two network monitor rules for it.
the first one i have moved up to 3rd place (Id 2), and it is for the “listen” port that you can set in the torrentprogram. It’s like this.
Action : Allow
Protocol : TCP or UDP
Direction : IN
Source IP : Any
Destination IP : Any (or use zone if you have one)
Source Port : Any
Destination Port : The listen port of your program

The second one is to get rid of those IGMP varnings… Is it secure? Nor sure, but i pass all leaktests and portscanners i have tested with. I Have it in 6th (Id 5) place. The rule look like this.
Action : Allow
Protocol : IP
Direction : IN/OUT
Source IP : Any
Destination IP : Any
IP Details : IGMP

Try these Network rules and see if it works.
Have a look at my image of the network rules. There you can see where Id 2 and Id 5 is.

When you have made the rules, right click the systray icon and exit the firewall, then start it up again. This is to be completely sure, that the new settings is applied.

[attachment deleted by admin]

Just to add to my previous suggestions, you can try to move those rules i suggested up and down to see if it works. Just don’t move them above the first two rules.

Try to reed the logs, and see what rule stops what… try to make new rules that allow the stopped connections…

If it still doesn’t work, try to go to security/network monitor and “turn off” network monitor, just to see if you can search now.