Screen Paver pops up firewall alerts

How can I get Comodo to stop popping up alerts asking for permission to let Screen Paver do its thing? I’ve tried various types of allowance, including saying it’s a Windows system app but it keeps popping up the permission request. I’ve also noticed lately that the keyboard no longer cancels the screen saver, it only unblanks the monitor. The mouse does cancel the saver as normal.

What happened to my system? How can I fix this?

I may also be having issues with Comodo firewall and Avast antivirus’ updates.

I don’t know what happened, but after a couple weeks this cleared itself up. Comodo no longer pops up for Screen Paver and keyboard presses stop the saver again (not just unblanking the monitor from black).

Unless it was maybe Glary Utilities that fixed it. But I thought this was fixed before I ran that.

Sorry no one got to before now, n0ukf, but glad it’s no longer an issue. Sounds like it took a little bit to get the right combination of rules and exceptions for it.

For other users’ benefit, would you mind posting details of your current Defense + rules for ScreenPaver, and any Exceptions that may be present?