Scheduled scan does update db even if disabled in settings [M388] [v6]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?: yes
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:

I have two default scheduled scans. The full scan is disabled, the quick scan is tweaked a bit and scheduled as weekly. The quick scan has “Update virus database before running” option unchecked, yet the virus signatures got updated. The database update job was not scheduled at the same time. I have noticed this issue since 2801.

  • If not obvious, what U expected to happen: CIS should not update DB if option is disabled
  • If a software compatibility problem have U tried the conflict FAQ?: no
  • Any software except CIS/OS involved? If so - name, & exact version: none
  • Any other information, eg your guess at the cause, how U tried to fix it etc: none
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware) attached, please PM for password if needed

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: 6.1.276867.2813, modified proactive

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: FW&AV
  • Have U made any other changes to the default config? (egs here.): yes (conf included)
  • Have U updated (without uninstall) from a CIS 5?: no
    [li]if so, have U tried a a clean reinstall - if not please do?: n/a
    [/li]- Have U imported a config from a previous version of CIS: yes, 2801
    [li]if so, have U tried a standard config - if not please do: -
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used: XP SP3 32b, DEP, admin, no VM
  • Other security/s’box software a) currently installed b) installed since OS: a=none b=none

[attachment deleted by admin]

Hi Wilk

Thanks for excellent bug report

Could I just check, you are not running on a virtual machine?

Best wishes


Ach, forgot to add. No I don’t.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

After waiting long time for this issue to happen again while launching custom scans (and it didn’t) I can assume this issue is fixed now.

Thanks for checking this.

I’ll move this report to Resolved.