Scanning with Latest Version of CCE 6.0

Hi all,

The Other day I ran a full scan with CCE 6.0 and the whole scan took 11 hours 42 mins which I thought was a bit long. I have run CCE 6.0 with a Full scan in the past and the scan was done just under 2 hours.

Therefore, I guess this is a bug with CCE.

The CCE version is: 6.0.264710.2708

My HDD size with all info on it as in used space is 15 GB

the Free space is 23.1 GB

Capacity: 38.1 GB

Total HDD size 40 GB

So I wonder has anybody else had this issue.

Thank again


(Extra Info There was No Problems found)

Edited: The wording of text

As I see for myself, those 709 members on this forum have seen my post, but I guess no one has had this issue as I have witnessed.

Therefore, I thought it is about time I log it as a bug, and submit it so it can be verified.

Thanks again


What I’m going to do is hang fire and see if somebody has this issue before I bug report it.

also what is the Bug report LINK for reporting CCE problems ? Is it the same one? and if so what is the Link or clickable link. Since I forget.

Thanks again


Hi Nigel,

It seems way to much time for just 15GB, only if there would be a lot of compressed files on it it might make sense.
Can you check to see if you CPU is maxed out during scan? I think this justifies a bug report as time v.s. size doesn’t seem right.

Hi Ronny,

Thanks for replying to my issue!

  • First of all I check often for compressed files (So I don’t think, there is an issue there)

  • When I ran this Scan I had no internet Access to this Computer, I unplugged the Ethernet cable to Computer and used my laptop in a different location.

  • I checked the scan about 1 hour later and it was at 48% done

  • usually at this time it’s about 60% done

  • Therefore, I opened up Task Manager under windows and the CPU was showing 100% usage

  • Therefore, I left and came back 1 hour later; the scan showed 55%, and the CPU was still 100%

Therefore, I left it again, came back to my PC after 4 hours, and was at 60%, So that point I wrote down on paper the progress of it.

So I left it again and came back 7 hours later after starting the scan and it showed 82%, So that point I said to myself this is a bug here, I will have to ride this out and write down when this finishes.

I came back to my PC to check the progress just less than 10 hours and it read 93% I rechecked CPU and showed 100% still

So I came back and looked at my PC and it said scan complete and it read 11:42:18 and the top said The System needs to reboot to complete scan So I pressed reboot and my system rebooted. When it came, back CCE started so I press yes and it came up and showed a monitor symbol that was green and blue tick across the monitor symbol and under that it said No Treats found.

So then, I shut down my PC and came back on the 25th Feb to log my report as shown on first post.

Sorry I did not do my first post like this, so hope this fully explains all.

Other info about my Computer My Processor is AMD Athlon 64 3200+ 2.0 GB RAM

My Processor is set as it is, as in not over clocked

Therefore, I hope this information helps now

Thanks again


Did you post a bug report already?
I can’t find one here

If not please do and refer/link to this post please.

I have not yet but I will do, I was not sure to post it there. But since you told me, I will do it.

Thanks again Ronny


Thanks, could you test something else, and run the scan with a live internet connection.
It could be that certain time-outs on request are not handled correctly for example causing high scan delays

Hi Ronnie,

I have run CIS 6.0 Full Scan with Internet Connection and I get no issue and the scan is finished in under 25mins.

I have even tested CCE 2.5 a long time ago before CIS 6.0 came out on beta and I had no issue with a full scan and even with a Internet Connection.

So I don’t know what I can do next. Shall I try a Smart Scan with Internet Connection, and type out the time it takes to scan? I will do the test with CCE version is: 6.0.264710.2708

So what do you think Ronny, or anybody else

Thanks for your help and advise so far


So to recap, a full scan with Internet connection takes 25 minutes, the same scan same system without Internet connection takes over 11 hours right?
That smells like to high time-outs on Internet queries / File lookup service, there is nothing you can do about that, just file the bugreport, link it to this post and it’s up to the dev’s to fix it.

Hi Ronny here is the Recap. a full scan with Internet connection takes 25 minutes YES to that but that is with Comodo Internet Security 6.0

the 11 hour scan is with CCE 6.0 with a full scan no Internet

Sorry If I got it confusing

But I did post all info on bug report which is there if you wish to see.

Also Yes for all the same system.

Can you try CCE scan with Internet to see if that makes difference?

Hi Ronnie I will do that.

So a full scan with CCE with Internet


P.S. I hope it don’t run like it did on the 24th of Feb :THNK

I will do it tomorrow morning.

Thanks again


I Start of Full Scan with CCE: 9.01 am I checked the CPU and it showed 100% Internet is on also

First part of Scan is Memory from 0% to 49% that was done in 7 minutes

Then it change to scanning MBR Still 49% at 7 minutes 1 second

Now it changed to Scanning Files and it is still at 49% at 10 min 24 seconds

Checked CPU it’s Ranging from 74% up to 100%

Scan still at 49% at 15 minutes

I got back to PC and check and it shows 57% Duration: 00:47:10 CPU 98%

It changed to 60% at 00:59:02 I opened up CPU shows 100% and holding. (I do not have it running next to clock)

I walked away from PC and it was at 67% at 01:29:32

Got back to PC and it was at 69% and showing 01:47:55 I still have Internet Connection

At 02:13:30, it shows 72%

At 02:55:00, it shows 77% opened up Task manger and Performance and it shows CPU 100% and Memory at 778mb then I pressed Red X to close screen.

As I was about to walk away it shows at 03:00:20 78%

I came back and Duration shows: 03:57:00 and scan is at 86%

At 90% the Duration shows: 04:25:32

Scan finished at 100% Duration shows: 04:27:22

(So I hope that helps Ronnie and for others to know also)


[attachment deleted by admin]

So the difference between a full scan without Internet 11h45m and with Internet 4h25m is quite large.
The only explanation I can reasonably find is that 7h20m delay for having no Internet is quite extensive.

Please don’t compare the scan times with CIS v6 because that uses a different approach, and scan optimizations etc.
CCE does a full ‘non smart’ scan of your entire system. but it seems to add 0.05 sec delay per scanned object if the lookup fails because there is no connection the ‘the cloud’.

Hi Ronny,

You pretty much summed it up!

Yes It is quite extensive. So I guess I can’t do much more.

As for CIS v6 scan I understand what you mean and I’m not counting on that.

So I guess it’s for the DEV’s to look at my info and come up with something ?

But I see you covered it Ronny so I don’t know? what can be said or done.

Also I did know that CCE gets info from the Cloud while the scan is taken place.

So I’ve learnt something there.

So Ronnie thanks for the feedback.

I will leave it up to you or the other Mods/Devs to come up with something, to go from next.

Thanks in Advance


I’ve notified staff on this and hope they find a solution to fix this in upcoming versions.

Many thanks Ronnie

and also thanks for your help and advice


Your welcome