'Scan my system' stops scanning after a couple of files (CPF X32)

Today, I tried to run ‘Scan my system’ for the first time. However, after scanning a couple of files, it keeps hanging on a file. It did not crash; I just can close the window, but CPF won’t scan the remaining part my HD, as it hangs every time on the same file.
I already tried to remove the file, but now it hangs on another file (and every time I restart the scanning, it is the same file).

1. CPU (32 bit or 64 bit)
Athlon 64 3000+, running 32-bit Windows.
2. Operating System information (including Service Pack Version)
Windows XP SP2 Dutch
3. Actively-running security and utility applications
Grisoft AVG Free
4. Specific symptoms of the bug, and steps you can take to reproduce it.
I just start ‘Scan my system’, and it hangs really soon after starting (after some seconds already). The file it stops on is the same; if I remove this file, another file will take his place and CPF will hang on that file every time I restart ‘scan my system’.
5. Specific steps you have taken to try to resolve it.
Restaring scanning.
6. Brief description of your Defense+ and Firewall+ mode (Custom, Train with safe) plus mention if you modified any setting in ADVANCED section of D+ and F+
Firewall: Train with safe
Defense+: Clean PC
In the advanced section, I added some rules for allowing P2P (i.e. uTorrent and eMule) to connect to the internet
7. If you pc reboots or you have a BSOD post in BSODs: Please add your minidump files here
I don’t have BSODs.

Version of CPF: