Saving Network Credentials

When I setup Comodo to save a backup to a network location such as my NAS, it asks for my login credentials EVERY time it goes to perform a backup. Why won’t it save them. If I map a network drive to that NAS, say Z:, and then use THAT as my storage location, it asks for login credentials AGAIN. Even if Windows 7 does not. For instance, double click Z: drive, can access it fine. Comodo still asks for credentials.


I’m having this problem too. I can’t run a scheduled backup because I have to enter network credentials. Is there a way to save them? Thanks!

Same here.
It seems Comodo tries hard to steer you to their cloud backup instead of your own nas.

Check in the Windows Task Scheduler that your backup job is running under your credentials.

I have 5 backups scheduled to a NAS and none of them ask for the credentials when they run.

Hope this helps,
Ewen :slight_smile:

The job is running under my name. Also: “run only when user is logged on” and “run with highest priviliges”.

I deleted it and recreated it several times with slight variations in the way I create the job (save schedule then point destination to nas, other way around, …). Or use the ip address instead of the network name of the nas.
Or running the job, then providing the credentials and hope it does not ask it again next time. But no… nothing helps. It asks for credentials every time.

Same problem here and I’ve wasted a lot of time trying to fix it, not to mention having to fill in the pass details for 6 separate jobs whilst trying to do something else.
CBU (4.3.7) was istalled with elevated user privileges - and appears to be owned by “System” - and appears to run with elevated privileges and as myself as user. The GUI page for Manage>scheduled task>edit has “remember password” ticked but any attempt to tick “remember connection” is never saved. Whether this would have any effect on auto-completing the log-on to my NAS I don’t know in any case.

It would be handy to know where the GUI actually stores the elected configuration of this page to gain some insight into whether the config is actually set or not, and from there maybe further investigation of the cause of this irritation would be possible.

This is W7 home premium, on AMD AT10-5800k APU processor 64bit OS btw.
The same problem occurs on an Intel run laptop tho’ off the top of my head I can’t be precise about other details.

Same problem here…can not unclick box and it requires a logon even though no logon is needed.

I even tried setting the drive to require a logon and still no success.

I can create a new job, run it once and it works. As soon as I schedule it, the logon appears and stops the program.

Hi all,

I’ve just rechecked everything and I can reliably do a backup to my NAS.

Comodo Backup was installed and runs under my credentials (not elevated).
NAS is mapped to a drive letter.
Identical user accounts exist on the source PC and on the NAS (therefore credentials flow across devices correctly).

The only hiccup I have is that occasionally it will fail on the Volume Shadow Copy if Outlook is running. I’ve gotten around this by running a BEFORE script that displays a message that the backup will start in 5 minutes. This gives me time to either save or complete any emails I’m working on. After 5 minutes, outlook.exe is killed and the the backup commences. An AFTER script then invokes outlook.exe.

Sorry, but I haven’t been able to replicate your issue no matter how I try.

Have any of you logged a support ticket at

You’ll need to create an account on the support server as the forum credentials do not flow across.

Let us know how you get on.

Ewen :slight_smile:

Thanks for the reply…I was starting to think you guys were gone…lol

I had not mapped the drive, but I can do so to see if that helps.

What I did do, is use a script to load Comodo, and from that, all the setting and locations were fine with no logons being required. So for now that’s just fine.

However, I do have one last problem…(other new posts)

I have set Comodo to Admin rights…
launched and ran backup on Full to cbu file, added exclusions for sys files and hidden and temp and ini…(I know redundant, but)
The backup ran at 100% …so great…
NOW…when I choose differential or incremental, same settings for all other things, the backup always fails at 99% with error 67, file not found.

Any suggestions?
I would be willing to ignore this error, but I want the program to close after finish and it will not do so with a error…
I have no idea what file it is looking for…

I don’t use a script to load Comodo. The scheduled tasks incorporates the BEFORE and AFTER scripts (These are set on the same page you set the macros). Try setting up a job to your NAS but don’t call it from a script, just schedule it in Comodo Backup. See if that makes a difference.

Ewen :slight_smile:

I was using the scripts because the setting (primarily the network drive) were not being saved after the first run. The mapped drive may have fixed that issue, but running scripts is fine with me.

My #1 issue is 99% completion so program stays open. If I could script a force close, that would be great. The BU is working better now that I have changed it’s properties to run as Admin…more files are being copied…

As I write this, I am doing a full, to cub backup and it appears to be working fine…expect a 100% completion. Where the issue seems to be is when I change that to full with simple, incre. with simple, or diff. with simple as follow ups for the master…hence, if I could do as above #1 issue, I would be happy.

Thanks again,