Sandbox & Virtual Kiosk issues [v6]

Hi everyone,
I’m reporting some issues I’ve noticed on CIS6, reguarding sandbox and VK.
I tried to use firefox in the CIS sandbox, but if i download something it crashes…freezes…and I have to kill the prcess using windows task manager. Same thing for the VK: it takes a lot to load, and if I run the browser inside it and I try to download something (e.g. ccleaner), it crashes.
This is the reason why I’m still using sandboxie…did anyone have the same problems??

I had similar issues with waterfox
Turns out explotshield was causing a conflict with waterfox
Since disabling exploitshield waterfox is running smooth

use download managers?
you did a clean install of CIS 6?

tried to download via kiosk thought I caught, but it was the download manager to the bottom and clicking to switch windows there was the download manager to the fund virtualized
as shown in the images below:
The 5th picture shows the download with download manager disabled

[attachment deleted by admin]

I filled out a bug report on Firefox and ice dragon in general.
they double autosandbox the flash plugin and are basically useless.
I am on windows 8 x64, don’t what other OS’s are effected.

check out this long post and formatted bug report Firefox/ice dragon.
Waterfox seems fine just really outdated.;msg644656#msg644656

I don’t use any download manager (at least in Firefox), and before installing CIS6 I uninstalled CIS 5 using Revo uninstaller (moderate mode), cleaned registry with ccleaner and regseeker, then rebooted and installed CIS6. Talking about the issues, I tried using IE and as I suspected everyting was ok…so actuallly is something related to firefox 17.0.1…anyway…no problems for me: Firefox is my default browser and I can sandbox it using sandboxie, waiting for the bug fixing by Comodo :wink:

Yea i wish they would contact me about the firefox/ice dragon thing it is sandboxed and i am typing with the flash player sand boxed as we speak. i am writing this with ice dragon believe it or not. I am running windows 8 pro x64. like to give them some full dumps or whatever. i suppose i will install firefox again and see where it goes.I installed firefox and am using it now testing and testing. so far so good.but flash movies don’t work in ice dragoon now lets see if i can in firefox…

that’s a flash movie and it certainly won’t play in Firefox 17.01. i look in the sandbox and see two flash player plugins. darn…bug… :-\

I am in contact with comodo about another bug besides Firefox.

I have sent them email asking if they have time to get to this one yet.

Update I have been working with Comodo Staff on another bug.
I sent them email about firefox. QA is trying to reproduce it now.
They did suggest to try running it in virtual kiosk desktop mode
“C:\Program Files\COMODO\COMODO Internet Security\virtkiosk.exe” -d
i made a shortcut as you can see that has a -d switch on the end. this is where the 64 bit version of comodo is installed. if it’s 32 bit i would think it’s on c:\program files (x86)\comodo

The point is
1)reset your sand box 1st every time before trying the -d with virtkiosk (I am working on the kiosk bug with the staff)
2)launch the virtual kiosk in desktop mode and try Firefox or Ice worked great for me and i was able to watch flash movies etc.Fast surfing. but it did still sand box the flash player plugin.

this is just something they have had me try for now.Remember though I am Windows 8 Pro x64 8 gigabytes of ram and an Intel Quad Core 2.5ghz. So results may vary

Hi guys

I guess this has become a ‘what is or might not be working’ topic re virtualisation. For the devs to take action unfortunately I need formatted reports on each issue.

If it’s OK I’ll move this to D+ help for the moment, but would greatly appreciate individual reports on each issue as you clarify them.

Best wishes


No Need. it’s under control i am testing all sorts of scenarios with comodo support now. if they request more formatted bug reports i will provide them.I am in communication with them by email daily.

We very much appreciate your work on Comodo’s behalf, DR Haze.

I don’t think you mean to discourage reporting of bugs coming out of this discussion, as you are rightly encouraging bug reports elsewhere. But this post could be read as such, Obviously different machines may have different bugs.

I guess what you mean is no-need to fully report bugs that have already been reported. Which is a point, but actually it is of value to add good quality reports to the same topic. Can help the devs a lot.

Let’s see what come in from this trace which may grow longer…


Forwarding to D+ help

Best wishes