Sandbox Issues (BSOD & Edge)

I encountered two problems with the sandbox, I start with the one that I think is most important:

In some cases when I reset the sandbox, and there are apps running in the container, I get a BSOD that freezes the PC and makes the processor work (I can hear the fans going full power) but the HDD light stays off, so I have to shut down the PC by holding the power button.

I don’t know if the error I find every time I run the diagnostic test has anything to do with this.

While the second problem is about starting Microsoft Edge in the container, the browser opens, but keeps loading about:blank, and “Downloading proxy script …” appears at the bottom. Likewise, pasting a URL into address bar leaves it constantly loading without displaying anything.

I think I have found the cause, if the settings are changed to virtualized Chrome, CIS creates in the container, the “Secure Preferences” file in the folder “C:\VTRoot\HarddiskVolume6\Users***\AppData\Local\Google\Chrome\User Data\Default" which I think is the cause of the BSOD when trying to empty the Container. If I try to delete the VTRoot folder manually from the file explorer, CIS returns the message attached below, which says more or less “explorer.exe is trying to change your browser settings” by clicking on the first item “Keep current browser settings” the folder was not deleted, because the deletion of the “Secure Preferences” file was blocked, while clicking on the second item” Change the current browse settings "I was able to delete the folder.

So in theory, until I try to change the settings from virtualized Chrome, I should be able to empty the container normally, but I hope in the future there may be a fix to this problem/bug.

No it is a bug that will be fixed in an upcoming release, I had this issue without doing anything other than just running a chrome based browser in containment and then using reset containment task.

You’re right, what I wrote is valid only for Chrome, I tried with Edge (Chromium) and I got a BSOD trying to restore even after closing the processes left open in the container, and manually removing the VTRoot folder.