Sanbox is not allowing my application

I have two accounts in my computer a administrator, and a standard user…No problems in the administrator but I do experience difficulties in my standard account, and I think the culprit is Comodo SandBox.

I have added the a program that didn’t ran(texttwist.exe) in the sandbox database (add a program to the sandbox) and set it to unrestricted.
When I exceute texttwist after…texttwist crashed…But when I attempt to ran texttwist in the “run a program in the sandbox” and set it to run in unrestricted it executes with no problem…why is sandbox not automatically checks its database for unrestricted applications? I could ran this program this way but it is hassle

Can anyone give me some advice?

Yeah, that’s how is Sandbox working: crashing apps. Welcome in the club.

Try to add texttwist.exe to My Own Safe Files which is placed in Defense+ → Common Tasks tab. In theory CIS should stop sandboxing applications added there, but practice proves different.


I’ve tried adding the application to the my own safe file, I even tried adding the folder so the whole directory would be considered safe, but still the app crashes.

another thing is … uf you are user of vista/7 try to disable uac, reboot and then try run it again

Simple answer---- Sandbox= problems
Disable it.

Well, even a safe application can be sandboxed if the parent application is sandboxed. Make sure that the process tree isn’t sandboxed. You can use Process Explorer to do that. Just double click on the texttwist.exe in Process Explorer. If it has Job tab in Properties window then switch to it and see the Job Name and whether there are or not any Job Limits.

The parent process of texttwist is explorer.exe, explorer is already marked as safe file.
but still the texttwist crashes on the standard account, but ran properly in the admin account.

Texttwist also ran fine in the standard account only when I use the “open account in the sandbox” program.

Why does texttwist failed to run even its already added in the sandbox database? but can executes fine when opened by “open account in the sandbox” program.?

Most likely because some kind of bug in CIS. You should file a bug report in Bug Section of the forum, but I think you should get more devs attention if you post it in the thread linked bellow.

COMODO Internet Security 4 and Application Incompatibility Problems Reporting

Yes pls file a report asap so that we can investigate it.
These type of incompatibilty issues will raise its head from time to time. We are here to resolve them all!


Disable Sandbox and everything will be OK, someone said.

Well, easier said than done. Tried and failed in my case.

Application in question - Girder.


I will post more related information to the bugs thread…
I already tried disabling sandbox box, the problem still persist.